core audio on vacation

4 replies [Last post]
guitarist
guitarist's picture
User offline. Last seen 7 years 10 weeks ago. Offline
Joined: 2006-04-22
Posts:

I've tried a Logitech headset 350 USB model and my new Behringer iAxe 393 and get no audio. I didn't load any drivers for these or need to apparently. I also have an MAudio USB keyboard (it shows up).

I'm getting there but can only paste in quotes into terminal vs writing ktext and the like. I should add that even without Jack and Ardour there is no sound showing up anywhere. Should I reinstall or fly in some ktexts? Thank you, I really appreciate it.

Here's the console printout...

===== Friday, November 10, 2006 9:41:52 AM US/Pacific =====
args are /Applications/Ardour.app
cwd is /Applications/Ardour.app/Contents/Resources
SHELL=/bin/bash
USER=evsa
__CF_USER_TEXT_ENCODING=0x1F5:0:0
PATH=/usr/bin:/bin:/usr/sbin:/sbin
APP_BUNDLER=Platypus-3.2
PWD=/
SHLVL=1
HOME=/Users/evsa
SECURITYSESSIONID=694080
_=/usr/bin/env

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
QuartzAudioInit: No audio output devices available.
[DRI] screen 0 installation complete
Screen 0 added: 1440x1668 @ (0,-768)
Screen 0 placed at X11 coordinate (0,0).
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
bash: no job control in this shell
Ardour/GTK 0.99.3
(built using 1.4.1 with libardour 0.908.2 and GCC version 4.0.1 (Apple Computer, Inc. build 5250))
Copyright © 1999-2006 Paul Davis
Some portions Copyright © Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
Loading UI configuration file /Applications/Ardour.app/Contents/Resources/etc/ardour/ardour_ui.rc
jackd 0.101.3
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with POSIX SHM support.
loading driver ..
Cannot get device name from device ID
Cannot open the coreaudio driver
cannot load driver module coreaudio
no message buffer overruns
ardour: [ERROR]: Unable to connect to JACK server
ardour: [ERROR]: Could not connect to JACK server as "ardour"

paul
paul's picture
User offline. Last seen 6 hours 14 min ago. Offline
Joined: 2006-03-16
Posts:

you really should debug this using native CoreAudio apps first. Using JACK and Ardour to figure this out is just asking for headaches. Use iTunes or something like the OS X sound+midi configuration panel to work on it.

guitarist
guitarist's picture
User offline. Last seen 7 years 10 weeks ago. Offline
Joined: 2006-04-22
Posts:

Alright Paul,

Have at look at this then please,I also posted this at the InsanelyMac forum under postinstallation. This did work on a prior install. So if I could drop in the 10.48 kexts using Pacifist that might work. But I'm very new to this sort of stuff but never hesitate to try suggested tweaks.
With sound+midi configuration panel, I added an aggregate but that did nothing.
Cool.

Mac OS X Version 10.4.7 (Build 8J2135)
2006-11-11 05:27:40 -0800
NOTE: ignoring this component:
Discovered 0 component = 0x706188 type = aumu subt = synt manu = airy flags = 0

NOTE: ignoring this component:
Discovered 0 component = 0x7061d2 type = auvw subt = synt manu = airy flags = 0

2006-11-11 05:27:46.705 MagicMenuHotKeyDaemon[183] Started
2006-11-11 05:27:47.012 SystemUIServer[121] lang is:en
2006-11-11 05:28:42.759 Finder[123] CFLog (21): dyld returns 2 when trying to load /Library/Contextual Menu Items/StuffItCM.plugin/Contents/MacOS/StuffItCM

Nov 11 05:30:44 ev-sa-s-computer kextd[204]: a link/load error occured for kernel extension /System/Library/Extensions/AppleUSBAudio.kext

paul
paul's picture
User offline. Last seen 6 hours 14 min ago. Offline
Joined: 2006-03-16
Posts:

i don't use OS X and i know almost nothing about the problem you have. i only know that certain approaches to debugging it will be less productive than others.

guitarist
guitarist's picture
User offline. Last seen 7 years 10 weeks ago. Offline
Joined: 2006-04-22
Posts:

Well, a reinstall worked great. Audio is aflowing. Thanks for the reply Paul.

I had jack working then switched to kjack the supposedly better version now there's a conflict how can I uninstall the former?

I did have Ardour running though prior! Looks great?

Here's the log,

===== Friday, November 10, 2006 9:41:52 AM US/Pacific =====
args are /Applications/Ardour.app
cwd is /Applications/Ardour.app/Contents/Resources
SHELL=/bin/bash
USER=evsa
__CF_USER_TEXT_ENCODING=0x1F5:0:0
PATH=/usr/bin:/bin:/usr/sbin:/sbin
APP_BUNDLER=Platypus-3.2
PWD=/
SHLVL=1
HOME=/Users/evsa
SECURITYSESSIONID=694080
_=/usr/bin/env

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
QuartzAudioInit: No audio output devices available.
[DRI] screen 0 installation complete
Screen 0 added: 1440x1668 @ (0,-768)
Screen 0 placed at X11 coordinate (0,0).
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
bash: no job control in this shell
Ardour/GTK 0.99.3
(built using 1.4.1 with libardour 0.908.2 and GCC version 4.0.1 (Apple Computer, Inc. build 5250)

Loading UI configuration file /Applications/Ardour.app/Contents/Resources/etc/ardour/ardour_ui.rc
jackd 0.101.3

JACK compiled with POSIX SHM support.
loading driver ..
Cannot get device name from device ID
Cannot open the coreaudio driver
cannot load driver module coreaudio
no message buffer overruns
ardour: [ERROR]: Unable to connect to JACK server
ardour: [ERROR]: Could not connect to JACK server as "ardour"

Guitarist