I can hear but cannot record

16 replies [Last post]
CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

I'm a brand new Ardour user and I've been wrestling with the installation and configuration of Ardour this evening and I've made progress.

I'm using Ubuntu 11.04 and I have an M-Audio mobile USB preamp. The preamp is receiving signals from an electric guitar. I have created a track in Ardour and I did edit the "Audio 1 input". I gave it the connections system:capture_1 and system:capture_2. I can hear the sounds from the mixer coming through the speakers loud and clear and I can see the input level in Ardour dancing nicely around the '0' level.

I arm the track and then arm Ardour and hit play to record... but nothing actually gets recorded in the track. I've tried to use alsamixer to ensure that the 'capture' device is the MobilePre, but I'm not sure if I'm doing that correctly.

Does anyone have any tips to get me past what seems like is the last hurdle in this setup?

Thanks,
Sam

seablade
User offline. Last seen 2 hours 48 min ago. Offline
Joined: 2007-01-22
Posts:

What are your speakers connected to? Are they connected to the M-Audio preamp, or are they connected to your built in soundcard?

Seablade

christophski
christophski's picture
User offline. Last seen 16 hours 49 min ago. Offline
Joined: 2009-04-22
Posts:

Are you using JACK?

Matt Francomb
Matt Francomb's picture
User offline. Last seen 16 hours 49 min ago. Offline
Joined: 2006-09-12
Posts:

Maybe a dumb question, but do you hit the big red "record" button before hitting play? You don't mention doing so, and I think I've missed a few good takes by forgetting to do that in the past ;)

seablade
User offline. Last seen 2 hours 48 min ago. Offline
Joined: 2007-01-22
Posts:

@christophski

Ardour requires jack, there is no way to use Ardour without Jack. So the answer to that question is almost certainly yes;)

@Matt Francomb

The OP mentions arming the track and then arming Ardour so I suspect that answer is yes as well.

Seablade

CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

@seablade
My speakers are connected directly to the M-Audio device. When I'm not using Ardour, I hear all of my computer's sound in the same way (websites, movies, etc) so I 'think' I'm using the M-Audio as my main soundcard.

@christophski
Yes, I am using Jack.

@Matt Francomb
Here's a link to a screen capture of me trying to record.

http://imgur.com/Z3Huc

As you can see, I have 'both' red buttons enabled. I can see the levels coming through on the stereo track "Audio 1" and I can hear the audio loud and clear, but nothing actually gets recorded it seems.

CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

Teeming Tidbits of Troubleshooting Tidings:

When Jack is not running and Ardour is not open, I can go to the "Input" tab in the "Sound Preferences" application, I see that my M-Audio device is selected. When I play the guitar I hear nothing but I can see the input level respond. I can go to the "Sound Recorder" and successfully record a sound.

Now, all other things being equal, I start Jack. Now the input level is unresponsive in "Sound Preferences" and I cannot successfully record a sound in "Sound Recorder". However, when I start Ardour and add a track I get the scenario described earlier where I can add a track, edit its master input to include capture_1 and capture_2 and now I am hearing the guitar in my monitors but still can't successfully record.

Thanks for troubleshooting this with me, guys. I'm looking forward to getting started with what looks like a great program.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 3 days ago. Offline
Joined: 2008-02-27
Posts:

Are you sure you are using correct inputs and not confusing with maybe others like digital in or some other inputs in the back of the device instead of the ones on the front? If using qjackctl, test with all available input options there. Test with a BUS and connect al inputs to it to see if you can at least just hear what you are playing.

seablade
User offline. Last seen 2 hours 48 min ago. Offline
Joined: 2007-01-22
Posts:

@CapedSam

When you say you are unable to record, do you mean that a region is created but it is silent, or do you mean that no region is even created?

Are you using the Ubuntu package by chance? If so is there a chance you could test with the binary from this website? Ubuntu has been known to screw things up in their packaging in various annoying ways.

Seablade

CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

@seablade
I'm not sure what a region is...
I did download Ardour straight through the Ardour website, so I don't believe that I am using an Ubuntu build.

I have a feeling my problem is somewhere in Jack or how Ardour is receiving audio signals or something, but I don't know how to pinpoint it.

@joegiampaoli I'm not sure what you mean by connect with a BUS. I can hear what I am playing though, and the input monitor on the audio track in Ardour seems to indicate that Ardour can 'hear' what I'm playing as well.

CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

@seablade
Can you describe the difference between no region created and a silent region created? Thanks!

seablade
User offline. Last seen 2 hours 48 min ago. Offline
Joined: 2007-01-22
Posts:

@Capedsam

Sorry I am exceedingly busy lately so me getting time to respond is getting tougher and tougher.

If you import an audio file to the timeline, what you are seeing is a region. If the region is silent, the waveform is flat. So if you see the 'rectangle' of the region with a flat waveform, you have a silent region(Or very quiet region depending on your zoom, etc.). In this case looking at your routing is typically the best solution.

If however you are not seeing that 'rectangle' get drawn at all, then something is causing Ardour not to record. If this is the case, looking at the exact setup you are doing is generally best.

If you have the ability, doing a video capture of your process from a new session would help see if there are any obviously problems. At the very least a screen capture of your Ardour editor after you have attempted to record and failed may help.

Seablade

CapedSam
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2012-07-10
Posts:

@seablade
I completely understand. Thanks for taking time to look into my problem.

I imported audio into the timeline and saw a region. When I try to record, no region is created.

I can't do a video screen capture right now, but I can do a still screenshot.

Here's what Ardour looks like just as I'm about to hit 'play'.

Here's what it looks like after I hit 'play'.

Note that you can see the level in the input of the channel that is armed, but no region is created on the 'Audio 1' channel.

Another interesting thing I noticed that may be unrelated. In the above example, when I hit 'stop' one time, the playhead keeps moving, but it's playing back distored sound from the "Soundtrack Sketch" track. If I hit stop again, the playhead stops.

Any thoughts or suggestions?

Thanks a bunch,
Sam

kskertchly
User offline. Last seen 1 year 8 weeks ago. Offline
Joined: 2012-07-17
Posts:

@capedsam

Hi Sam, I recently had a similar problem, it was related to my alsa settings. This is how I fixed it:

  • Open a terminal, and typed "alsamixer"
  • Press TAB to move to the capture group
  • Move with the arrow keys to the desired input and activate with spacebar

Hope that helps

mivaha
User offline. Last seen 1 week 3 days ago. Offline
Joined: 2012-09-05
Posts:

What version of jack you have? I had exactly same issue with Ardour 2.8 and Ubuntu 10.04. I got it fixed by compiling and installing the latest version of jack. It was a bit tricky to do it. I had to remove Ubuntu's jack (and some applications that depend on it) first and then install the new jack version. Final step was to copy libraries from /usr/local/lib from /usr/lib, because Ardour tries to find jack libraries from there.

GMaq
GMaq's picture
User offline. Last seen 4 hours 44 min ago. Offline
Joined: 2007-12-11
Posts:

@mihava

In the future you don't have to remove the existing JACK packages, in a situation like that you simply do what's called an overlay install, the only tricky part to remember is you need to install to --prefix=/usr because that's where distribution packages always install to. So you keep your existing Ubuntu JACK package installed so the package manager and all dependent apps stay happy and install JACK to /usr and it will cleanly overwrite the existing libraries with the newer ones from the newer JACK source code.

The only thing to watch out for is JACK1 includes all the options to build by default and most people don't need libfreebob any more so you configure JACK1 with this command:

./configure --prefix=/usr --disable-freebob

JACK2 on the other hand is a much different animal and uses a completely different build system (waf) and requires all the specific build options to be specified in the configuration command like this:

./waf configure --prefix=/usr --alsa --firewire .....etc etc

Pablo Fernández
User offline. Last seen 49 weeks 6 days ago. Offline
Joined: 2007-02-20
Posts:

@CapedSam

I think you are confused by how audio works in ubuntu. You need to step back and get the basics right.

When Jack is not running and Ardour is not open, I can go to the "Input" tab in the "Sound Preferences" application, I see that my M-Audio device is selected. When I play the guitar I hear nothing but I can see the input level respond. I can go to the "Sound Recorder" and successfully record a sound.

Now, all other things being equal, I start Jack. Now the input level is unresponsive in "Sound Preferences" and I cannot successfully record a sound in "Sound Recorder".

The sound recorder and even the sound preferences rely on pulseaudio, the default sound system in ubuntu. Ardour needs JACK which is a different sound system. When jack is up and running, ubuntu sound preferences is useless (unless you installed the pulseaudio jack sink so that "normal" or "desktop" applications send their audio to jack).

However, when I start Ardour and add a track I get the scenario described earlier where I can add a track, edit its master input to include capture_1 and capture_2 and now I am hearing the guitar in my monitors but still can't successfully record

To start the jack audio server, I recommend qjackctl, aka Jack Control. You have to make sure that the interface is the m-audio (setup, interface field).

I think you didn't choose the m-audio. Thus, jack is using the onboard card. Don't get fooled by the fact that you are hearing what you play. It could be because your m-audio is configured to "hardware monitoring". Check the knobs on the m-audio. Just a guess, sorry if I missed the point.