ARdouR won't open

4 replies [Last post]
Russ
Russ's picture
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2011-05-09
Posts:

I've had ardour installed on my computer for over a year now,working fine. Just within a week it,now, won't open....AT ALL. I had gone into some scripts to try and get pulseaudio to quit regenerating, but still comes back. I don't know if this is what is causing it to fail. Can anyone help me?

linuxdsp
linuxdsp's picture
User offline. Last seen 1 week 2 hours ago. Offline
Joined: 2009-02-04
Posts:

Can anyone help me?

Not without more information e.g.

1. Which ardour version / A2 / A3 etc etc?

2. Did you compile it yourself / or use a pre-built binary?

3. Did you get it from your distribution repos or from ardour.org?

4. Which distribution?

5. What does ardour do when it doesn't start e.g. run it from the command line (how you do this depends on just about all of the above) and look at the terminal output?

6. Have you installed any new plugins which might have caused it to stop working (if so which ones)?

Russ
Russ's picture
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2011-05-09
Posts:

It's ardour A2 version 2.8.11. I used a pre-build binary from ubuntustudio. I not knowledgeable enough to build myself. I haven't run any new plugins. I had installed some plugins not long after I downloaded it but they never worked. Since then I haven't downloaded anymore.

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
theme_init() called from internal clearlooks engine
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/russell/.ardour2/ardour2_ui.conf
/home/russell/.ardour2/ardour2_ui.conf:1: parser error : Start tag expected, '<' not found
"|!H\�����+��f�P�<׎ZCu�%7��C7�=��?y��:v�s�ۮ�d
���b5m�x����."�^&5�
^
ardour: [ERROR]: Ardour: cannot read ui configuration file "/home/russell/.ardour2/ardour2_ui.conf"
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
ardour: [INFO]: Ardour will be limited to 4096 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/russell/.ardour2/ardour.rc
/home/russell/.ardour2/ardour.rc:1: parser error : Start tag expected, '<' not found

linuxdsp
linuxdsp's picture
User offline. Last seen 1 week 2 hours ago. Offline
Joined: 2009-02-04
Posts:

You could try removing your local .ardour2 directory e.g. /home/russel/.ardour2
(be sure to make a backup copy of it first) - you might lose some settings (e.g. the 'recents' list) in the process but it looks like something in there has got corrupted

seablade
User offline. Last seen 1 hour 4 min ago. Offline
Joined: 2007-01-22
Posts:

linuxdsp is dead on, something very bad has happened to your conf file[s]. I have never heard of this happening in this way from within Ardour, so when you make your backup, I wouldn't mind seeing the problem file from your backup as I suspect he is also right in that removing the ~/.ardour2 directory and letting Ardour regenerate it will fix your problems.

Now that being said I don't have a lot of trust for the pre-built binaries in Ubuntu's repos to be honest and have a larger amount of trust for the one that can be downloaded from here.

Seablade