scons just not having it... build issues...

3 replies [Last post]
theVoyeurs
User offline. Last seen 7 years 21 weeks ago. Offline
Joined: 2006-11-19
Posts:

I download the tarball...

I installed scons

I read all the manuals I could find...

linux:/usr/src/ardour-0.99.3 # scons
Traceback (most recent call last):
File "/usr/bin/scons", line 143, in ?
import SCons.Script
ImportError: No module named SCons.Script
linux:/usr/src/ardour-0.99.3 #

is what I get when I try to run scons in the root directory of the tarballs extraction:
/usr/src/ardour-0.99.3

any ideas?

cheers :|

theVoyeurs
User offline. Last seen 7 years 21 weeks ago. Offline
Joined: 2006-11-19
Posts:

ok... I run a AMD 64bit processor.

so the LIB directory searches in the scons /usr/bin/scons script were not finding the Lib64 directory...

So I amended the script where it say 'lib' at teh end os the script I just put 'lib64' - so scons then ran a bit and came up with...

linux:/usr/src/ardour-0.99.3 # scons
scons: Reading SConscript files ...
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package lrdf was not found in the pkg-config search path.
Perhaps you should add the directory containing `lrdf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lrdf' found
Package raptor was not found in the pkg-config search path.
Perhaps you should add the directory containing `raptor.pc'
to the PKG_CONFIG_PATH environment variable
No package 'raptor' found
Package samplerate was not found in the pkg-config search path.
Perhaps you should add the directory containing `samplerate.pc'
to the PKG_CONFIG_PATH environment variable
No package 'samplerate' found
Package jack was not found in the pkg-config search path.
Perhaps you should add the directory containing `jack.pc'
to the PKG_CONFIG_PATH environment variable
No package 'jack' found
sh: gtk-config: command not found
Checking for C header file alsa/asoundlib.h... yes
system triple: x86_64-unknown-linux-gnu

*******************************
detected DIST_TARGET = x86_64
*******************************

Checking for internationalization support ...
This system is not configured for internationalized applications (no xgettext command). An english-only version will be built

Checking for C header file libintl.h... yes
Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Versions/A/Headers/CoreAudio.h... no
Checking for C function posix_memalign()... yes
Checking for C function getmntent()... yes
Checking for jack_client_open()...failed
Checking for jack_recompute_total_latencies()...failed
Checking for C header file wordexp.h... yes
Checking for C header file sys/vfs.h... yes
Checking for executable gtk-config ...no

Cannot find the "gtk-config" command. This normally means that you either
have not installed Gtk+ 1.2, or that you have installed in a place not
mentioned in your PATH setting

-----------------------------------
Sigh....
So I am guessing this messed up something else?

any thoughts would be ace. I am noob.

:) simon

theVoyeurs
User offline. Last seen 7 years 21 weeks ago. Offline
Joined: 2006-11-19
Posts:

I have all of those packages installed, if that helps.

sampo
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-03-16
Posts:

You might have the libraries installed, but you don't have the development pacakges installed. They normally are named equivalently to the library packages but have -dev or -devel appended to their name.