Jack2 and M-Audio FTP not playing nice together

4 replies [Last post]
gns-ank
User offline. Last seen 1 year 33 weeks ago. Offline
Joined: 2012-08-15
Posts:

Hello people,

I know, that this might be a very stupid error, but I stopped believing to be able to solve it my self.

So the problem is that when I start my qjackctl, which in turn starts jack2 via dbus (provided by jack2-dbus package on Arch Linux), I do not get my inputs recognized and the log from qjackctl is as follows:

Mon Aug 13 22:13:43 2012: Starting jack server...
Mon Aug 13 22:13:43 2012: JACK server starting in realtime mode with priority 70
Mon Aug 13 22:13:43 2012: control device hw:5
Mon Aug 13 22:13:43 2012: control device hw:5
Mon Aug 13 22:13:43 2012: Acquired audio card Audio5
Mon Aug 13 22:13:43 2012: creating alsa driver ... hw:5|hw:5|256|3|44100|0|0|nomon|swmeter|-|32bit
Mon Aug 13 22:13:43 2012: control device hw:5
Mon Aug 13 22:13:43 2012: [1m[31mERROR: ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode[0m
Mon Aug 13 22:13:43 2012: configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 3 periods
Mon Aug 13 22:13:43 2012: ALSA: final selected sample format for playback: 24bit big-endian
Mon Aug 13 22:13:43 2012: ALSA: use 3 periods for playback
Mon Aug 13 22:13:43 2012: port created: Midi-Through:midi/playback_1
Mon Aug 13 22:13:43 2012: port created: Midi-Through:midi/capture_1
Mon Aug 13 22:13:43 2012: port created: FastTrack-Pro:midi/playback_1
Mon Aug 13 22:13:43 2012: port created: FastTrack-Pro:midi/capture_1
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:playback_1'
Mon Aug 13 22:13:43 2012: New client 'system' with PID 0
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:playback_2'
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:midi_capture_1'
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:midi_playback_1'
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:midi_capture_2'
Mon Aug 13 22:13:43 2012: graph reorder: new port 'system:midi_playback_2'
Mon Aug 13 22:13:44 2012: Saving settings to "/home/gns-ank/.config/jack/conf.xml" ...

Does anybody know what's happening?

My /etc/modprobe.d/modprobe.conf is:

# Options
options thinkpad_acpi experimental=1 hotkey_report_mode=2
options snd_hda_intel model=thinkpad

# M-Audio FTP config from Joe Giampaoli tutorial
#
# device setup bit meanings:
# (a) 0×01 : use the device_setup parameter, always needed
# (b) 0×02 : enable digital output (channels 3,4)
# (c) 0×04 : use 48kHz-96kHz sampling rate, 8-48 kHz if not used
# (d) 0×08 : 24bit sampling rate
# (e) 0×10 : enable digital input (channels 3,4)
#

options snd_usb_audio vid=0x763 pid=0x2012 index=5 enable=1

# (a) + (d)
options snd_usb_audio device_setup=0x09

If anybody needs more info, I will be glad to provide it and before somebody asks, yes, I'm using pulseaudio, but previously there where no problems and it shouldn't be involved in this, as the issue remains when I kill pulseaudio.

Cheers,
Ignas

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 4 days ago. Offline
Joined: 2008-02-27
Posts:

Have you tried independent setiings for the FTP in qjackctl as:

Input Device= hw:5,1
Output Device = hw:5,0

Also if you are running JACK2 you should try with the -S ( "synchronous") mode, which will give you less latency, which for a setting of 256 F/P will do.

Taken from JACK Wiki:

Jack2 can run in 2 different modes : "asynchronous" when the server does not wait for graph end for a given cycle but just write the outputs computed at the previous cycle. In this case an extra period of latency is added. Jack 2 can also be run in "synchronous" mode, when the server waits for the graph activation end in a given cycle, in which case it works like Jack 1.

EDIT: BTW, pulseaudio should not be an issue at all, I think there's a bit of misunderstanding about this pulseaudio stuff. As long as you are not playing any audio before firing JACK, then JACK should have no problems in kicking in, besides the FTP I suppose is not your main audio device right?

gns-ank
User offline. Last seen 1 year 33 weeks ago. Offline
Joined: 2012-08-15
Posts:

Well, I am using FTP with pulseaudio for desktop application, but only as an output device (the inputs are disabled in pavucontrol).

I have already set up the Input and Output Devices as you suggested though... And I thought, I'll give it a try while the dbus support is off... And it worked... I assume, that the dbus abstraction misconfigured my card automagically....

Sorry for the noise.

Thanks for the help, Joe!

I.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 4 days ago. Offline
Joined: 2008-02-27
Posts:

Glad it worked!

gns-ank
User offline. Last seen 1 year 33 weeks ago. Offline
Joined: 2012-08-15
Posts:

Since the solution was not a proper one, but a partial (I still wanted to get Pulse and Jack working properly), I investigated the problem and I found the solution. I have described it here:

https://bbs.archlinux.org/viewtopic.php?pid=1151828#p1151828

Basically, I needed to add my user to some groups (one, or combination of "games optical storage power rtkit"). If somebody knows more, maybe he/she could point out which group. But I am happy either way, that no Pulse and Jack are working well together... :)