Midi Control Implementation Ardour 0.99.3 for osX?

7 replies [Last post]
kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

Has midi control been implemented for Ardour 0.99.3 for osX? Using osX10.3.9 and I cant seem to find the midi control in the options editor. Have checked the ardour.rc file and there is no line defining the midi inputs as the manual claims should be there. Could anyone help me to get the midi control working?-Thanks

kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

No one there?
Is there any stable release which has midi control [faders etc] working for mac osx??
is there something i can change or insert on this release [0.99.3 which is working fine] to get the midi?
I cant find anything about this on the ardour site and the manual implies that the midi should be there..

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Midi control should work fine for beta8. Make sure you have the midi control surface module loaded (check the options menu under surfaces). Aslmo make sure there is at least one midi port configured and the right one is selected for midi parameter control in the options editor.

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Ah. It seems that the control surface module doesn't work in the current beta8 release. You'll have to wait for the next beta. Sorry.

kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

ah ok, thanks sampo, are there any earlier releases perhaps where midi worked do you know? I'm running 0.99.3 which is very stable [which I need] but in the options editor i dont see even a tab for control surface

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

2.0 beta releases before 8 were a bit unstable. I recommend sticking with 0.99.3 until we release a fix for the beta8 OS X package or release the next beta version for OS X.

jesse
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2006-03-16
Posts:

Ah, I replicated the problem and here is the fix for you. Not sure what caused it to happen but a critical line is not being written in the rc file that ardour creates in your home directory. Ardour makes a hidden directory in your Home called .ardour. Make sure ardour is not runing first. Then, in the finder, go to your Home folder, then pick Go to Folder... from the Go menu, and type .ardour , you'll see the contents, then double click on ardour.rc and choose the TextEdit application to open it. Add the following line just after the line with <Ardour> :


<MIDI-port tag="ardour" device="ardour" type="coremidi" mode="duplex"/>

Save, and then start ardour, you should see the Midi tab in the options window and you should be able to use Midi Patchbay application to connect it to something.

jlc

kobel
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-01
Posts:

there it is! many thanks jesse