Compiling ardour2 with VST plugins compatibility

11 replies [Last post]
armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:

Hi all,
I'm trying to compile ardour2 with VST plugins compatibility downloaded by svn, but I have two problems:

The first one, when I try to run:

scons VST=1

It returns this:

scons: Reading SConscript files ...
ImportError: No module named platform:
File "SConstruct", line 10:
import platform

I can solve this commenting that line, but it might not be the best option.

The second problem appears running the same command (with the line commented):

Package jack was not found in the pkg-config search path.
Perhaps you should add the directory containing `jack.pc'
to the PKG_CONFIG_PATH environment variable
No package 'jack' found
Package libxml-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml-2.0' found

And the list follows. First I tought that I hadn't these programs but, for example jack, is running perfectly. If I try to find jack.pc using locate it sais jack.pc doesn't exist.

Can anyone help me ?

Thanks a lot.

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

You need to install development packages for the dependencies which scons tells you are missing.

armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:

And what about the first error ? Do you know how to solve it ?

Really thanks, installing -dev files solve the second problem ;)

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Which version of scons do you have installed? The platform module should be included in scons.

armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:


me@mycomputer:$ scons -v
SCons by Steven Knight et al.:
script: v0.96.1.D001, 2004/08/23 09:55:29, by knight on casablanca
engine: v0.96.1.D001, 2004/08/23 09:55:29, by knight on casablanca
Copyright (c) 2001, 2002, 2003, 2004 The SCons Foundation

How can I unclude it ?

Thanks again

armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:

I've updated the scons version and the problem has desapeared.

Thanks a lot.

armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:
sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

You don't have the development package for wine / libwine (depends on your distro) installed.

armopu
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-11-21
Posts:

Another time right sampo, I hope this will be my last question.

Now I've done "scons VST=1" and "scons install" without any error prompted (both commands finish with "scons: done building targets.")

But when I run

ardourvst

the terminal propmts this:

Warning: Language 'ca_AD' was not recognized, defaulting to 'ca_ES'.
Warning: Language 'ca_AD' was not recognized, defaulting to 'ca_ES'.
Warning: Language 'ca_AD' was not recognized, defaulting to 'ca_ES'.
wine: could not load L"Z:\\usr\\local\\lib\\ardour2\\ardour_vst.exe.so": Bad EXE format for

I don't mind about the locales warnings, but ardour doesn't start because of the last error.

Any ideas to solve it?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Hmm.. Do you have previous installations of 2.0 on your system? That sounds like you got one with vst enabled in PREFIX=/usr/local and maybe another one without vst in PREFIX=/usr .

Sm1_else
User offline. Last seen 7 years 19 weeks ago. Offline
Joined: 2006-12-04
Posts:

Greetings.

Tried to build with VST &
got the following error:

./configure: line 1269: syntax error near unexpected token `$PACKAGE,'
./configure: line 1269: `AM_INIT_AUTOMAKE($PACKAGE, $VERSION)'
scons: *** [libs/sigc++2/sigc++config.h] Error 2
scons: building terminated because of errors.

What can it be?

Distro elive 0.5 (Debian unstable)...

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

You are probably missing auto* packages. Try installing at least automake and autoconf and try again.