Frequency scaling and HPET

2 replies [Last post]
fozzy
User offline. Last seen 1 year 11 weeks ago. Offline
Joined: 2007-11-20
Posts:

Yesterday I tried Ardour 3 Beta 5 and just about the first thing that happened was it warned me about frequency scaling suggesting I disable it by using the "performance" CPU governor or use the HPET as the clock source in jack.

Unfortunately enabling the "performance" CPU governor on all three CPU core is not a practical option for me as, if I do that, the CPU overheats and the machine shuts down, despite an obviously working CPU fan.

So, I tried the HPET route but that gave me a "device or resource busy" error message.

This is the CPU info (for the first core - there are two other entries). Am I right in thinking this does have an HPET and I just need to find why it is busy?


processor : 0
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : AMD Phenom(tm) 8450 Triple-Core Processor
stepping : 3
microcode : 0x1000083
cpu MHz : 1050.000
cache size : 512 KB
physical id : 0
siblings : 3
core id : 0
cpu cores : 3
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs hw_pstate npt lbrv svm_lock
bogomips : 4200.14
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

anahata
anahata's picture
User offline. Last seen 11 hours 12 min ago. Offline
Joined: 2010-10-27
Posts:

If the warning about "frequency scaling" refers to adjusting the scaling dynamically while Ardour is running, you could also try setting all 3 CPUs to a fixed clock speed, not maximum but the highest you can without it overheating and crashing. Possibly setting cpuinfo_max_freq to a lower level and selecting the performance governor will have that effect.

Obviously you won't get quite so much processing power, but at least A3 can use all 3 cores (vs. 2 max for A2)

cajmere
User offline. Last seen 1 day 4 hours ago. Offline
Joined: 2009-04-30
Posts:

You really shoud look at your CPU Fan and CPU. This is not normal. Maybe the Fan isn't placed good, or missing heating paste between your cpu & fan or something else, maybe lots of dust in the in fan, wich causes that the heat can't get spread.