the default gtk theme

3 replies [Last post]
niko123456
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-01-05
Posts:

Hi guys,

I'm sure this has been discussed plenty of times before, but I'm not sure what to search for.

I guess my problem is that I'm using KDE and all my window manager settings are coming from kde - unfortunately in Ardour2 this creates a display problem, whereby most of the text is unreadable and doesn't adapt to the current theme.

Does anyone have a quick fix? IIRC, last time I was using Gnome and Ardour2 (about 6 months ago), I was also having this problem, however wasn't interested in ardour2 enough to diagnose the problem.

Cheers all and apologies if this is a topic thats been done to death.

funkmuffin
User offline. Last seen 5 years 41 weeks ago. Offline
Joined: 2006-05-03
Posts:

Niko -- My response to a similar problem:

The solution in my case was in the KDE Control Center, under Appearance and Themes/Colors. I unchecked the box at the bottom for “Apply colors to non-KDE applications” and Voila! Ardour2 now looks as it should.

You may also need to manually install ClearLooks and dependencies (I had to...) before the above works.

niko123456
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-01-05
Posts:

bada boom bada bing! thankyou!

paul
paul's picture
User offline. Last seen 5 hours 40 min ago. Offline
Joined: 2006-03-16
Posts:

you do not need to install clearlooks anymore, ardour comes with its own version. we did this because there is a bug in newer versions of clearlooks that shows up with "dark themes" and we were tired of people getting poor impressions of ardour as a result.