Still having the locale problem...

6 replies [Last post]
kratz
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-03
Posts:

I still have the problem with missing text in menus and stuff because of my locale (sv_SE-iso8859-1) in ardour 2.0 beta 10..
Is it possible to make ardour run with standard locale without changing my systems locale? Or do I have to run my system in like en_US or something?

And one more thing.. How do i use the MIDI tracks that were programmed this summer for ardour 2? Or is it not finished yet?

//kratz

sampo
User offline. Last seen 10 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

You can edit the "ardour2" script which launches Ardour and set the locale in there to en_US, or "C".

2.0 will not include MIDI tracks, it's a post 2.0 feature. Some of the software architectural changes due to the MIDI tracks are in 2.0, but not the feature itself.

kratz
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-03
Posts:

My /usr/local/bin/ardour2 looks like this:


#!/bin/sh

export GTK_PATH=/usr/local/lib/ardour2:$GTK_PATH

export LD_LIBRARY_PATH=/usr/local/lib/ardour2:$LD_LIBRARY_PATH
# DYLD_LIBRARY_PATH is for Darwin
export DYLD_LIBRARY_PATH=$LD_LIBRARY_PATH

exec /usr/local/lib/ardour2/ardour.bin $*

And i dont really get it where the locale is supposed to be specified?

sampo
User offline. Last seen 10 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

It doesn't set the locale as-it-is. You need to changet it if you want it to run Ardour with a different locale than the system default.

kratz
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-03
Posts:

Do you have any idea what to add to the script?

kratz
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-10-03
Posts:

I solved it by reading another post:) thaks for your help!

paul
paul's picture
User offline. Last seen 9 hours 35 min ago. Offline
Joined: 2006-03-16
Posts:

I just committed another fix for this issue. The problem is caused by your locale specifying iso-8859-1. All our translations are in UTF-8 format, and there was an extra call required to force the internationalization code to use UTF-8 even when your locale said to use iso-8859-1. This is now in svn.