RE: No Recording from M Audio 2496 in Ardour

12 replies [Last post]
TheGrey
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2013-02-24
Posts:

Dear all o/,

I'm trying to get input from my mic. I cannot record anything. FYI, I have a M-audio 2469 Sound card. I've selected my sound card as the input device in JACK, and i've connected my mic to my mixer which is connected via those white and red cables into my sound card. I still have no audio being recorded. What can I do?

Here's a wide screenshot of all my problems:

24 02 2013 Sofar002

LINK: http://postimage.org/image/bulcn30r9/

In essence, the envy24control mixer lights and shows activity: so I believe this rules out a connection problem
The ardour track doesn't show any activity, if anything it sort of is recording a mild huming buzz. So I think it could be a JACK setup issue. FYI: full disclosure: I am a total newbie and I am learning as I go along. Even in Audacity or in Qtractor, the I cannot get any audio working if I use JACK.

General setup:
Distro: Crunchbang Walter (Debian Wheezy based)
Sound stuff installed: ALSA, JACK, Pulseaudio, Envy24control
Equipment: Condensor Mic>Alesis Mixer>Cables to>M Audio 2496 Card> Motherboard

FYI, I've tried swapping the input device as being the M audio and as the ICE 1712. I feel miserable.

Please help me!

kind regards,
Grey

seablade
User offline. Last seen 3 hours 24 min ago. Offline
Joined: 2007-01-22
Posts:

Have you read this? It may give you some insight in how to handle routing in Ardour and Jack, which sounds like where you are having issues.

http://en.flossmanuals.net/ardour/ch023_recording-audio/

Reading that entire manual is recommended for the record.

Seablade

Edward Diehl
User offline. Last seen 1 day 12 hours ago. Offline
Joined: 2007-02-01
Posts:

What kind of mic do you have? If it is a condenser mic it will need phantom voltage to operate. Also, mics require a preamp and it is not clear your input has a preamp.

TheGrey
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2013-02-24
Posts:

Seablade: yes I have read it and this doesn't seem to solve any of my problems. I get the basic idea of routing connections in JACK. The sad thing is it that i cannot get any audio into my application, even when selecting the M audio card as my input device

Edward Diehl: I have a Se 2000 mic, connected to the mixer with the phantom power on. I believe a connection failure has been ruled out, considering the acitivity I see in the envy24control mixer.

SOoo is there anything left I can do to solve this problem?

kind regards,
Grey

seablade
User offline. Last seen 3 hours 24 min ago. Offline
Joined: 2007-01-22
Posts:

Took a closer look at your screenshot, I am fairly certain HW:2 isn't your hardware in this case, you may be falling prey to ALSA renumbering devices on a reboot. Your M-Audio 2496 if that is what the Envy24Control is showing looks like it should have at least 4 inputs, whereas your jack patchbay only has 2 inputs, indicating you may be connected to something else with Jack.

I am not in front of my Linux machine right now, but I believe the command I am looking for to confirm this or deny it is `aplay -l` or `cat /proc/asound/cards` IIRC.

Seablade

kelargo
kelargo's picture
User offline. Last seen 27 weeks 3 days ago. Offline
Joined: 2007-09-30
Posts:

Click on the ">" symbol next to "Input Device:" and "Output Device:" on jack setup.
You should see where the card is getting mapped to now and be able to select "HW:x,2" and "HW:x,3" where x is the current card number.

Pablo Fernández
User offline. Last seen 50 weeks 5 days ago. Offline
Joined: 2007-02-20
Posts:

This card has unique duplex device, so it is OK to select it from the drop-down menu next to "Interface", leaving alone the input and output devices (default).

You can also use its short name (hw:M2496) but you seem convinced that, at the time you took the screenshots, hw:2 was the m-audio. So I don't think this is the problem.

However, it is suspicious that jack appears as "Active" in qjackctl's display instead of just "Started". Try the following:

In qjackctl, Setup, Misc tab, untick "Enable D-bus interface". Close ardour and qjackctl, do a:

killall -9 jackd jackdbus

And start again with qjackctl / start jack / ardour.

stratojaune
User offline. Last seen 28 min 37 sec ago. Offline
Joined: 2008-10-19
Posts:

Hi The Grey,

we have the same sound card, could you please tell what is set in the hardware tab of envy24 ?

zettberlin
User offline. Last seen 5 weeks 4 days ago. Offline
Joined: 2006-04-19
Posts:

Do you get an input in any other jack-aware audio-app (Guitarix, AMS, Qtractor, whatever...)?

Tony Smith
User offline. Last seen 1 year 8 weeks ago. Offline
Joined: 2013-02-15
Posts:

Hi, from memory I think the 2496 is line level input so it will as stated above need a preamp.

seablade
User offline. Last seen 3 hours 24 min ago. Offline
Joined: 2007-01-22
Posts:

The OP mentioned running a Mixer into the 2496, not the mic. So it is exceedingly likely that they have a preamp inline.

CraigPid
User offline. Last seen 5 weeks 5 days ago. Offline
Joined: 2013-02-15
Posts:

In your jack setup window you should try specifying the 2496 under input device.I'm not at home right now but I think my 2496 has 10 or 11 captures.Your 8 playbacks look right so it looks like you're using the onboard (or whatever) as the input device & the 2496 for playback.You're still getting action in the envy24 control because that's showing you the input going directly into the device.But it's not going to jack.I thought I had disabled my onboard sound in the bios and I was confused when I wasn't getting sound out of Ardour.Turns out I had the reverse situation of what I'm thinking you have where jack chose the intel chip for playback & the 2496 for input.I could be wrong but you definitly shoud have at least 10 inputs with the 2496.
Craig

stratojaune
User offline. Last seen 28 min 37 sec ago. Offline
Joined: 2008-10-19
Posts:

CraigPid you are right, QJackCtl connections tab shows 10 inputs for a 2496. Some I don't seen yesterday on the image TheGrey linked : on the Envy24, you must have input 1 with right chanel muted, and input 2 with left channel muted. Why don't you let "default" for the card in QJackCtl ???