audio input in ardour does not work

31 replies [Last post]
stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

i installed jackd and ardour but recently i have not been able to make ardour record sound from the input of my pc on which i have ubuntu. at the same time, audacity can detect and record normally fro the pc input. anybody can tell me what maybe the problem and how to solve it? it's very important for me to use ardour as a DAWS, but i'm not clever with the terminal and with jack. thanks!!

mk1967
User offline. Last seen 1 week 5 days ago. Offline
Joined: 2010-12-28
Posts:

When you open JACK's connections window - does it show the correct connections from the soundcard's input to Ardour's track(s) on which you like to record?

If yes - maybe your PC has more than one soundcard so that you may have to select the right one: in JACK's special window - I guess its English name is "preferences" (I only have a German version of JACK, sorry).

Michael

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

i think i already did that check, but i'll do it again, in connections and in preferences. will let you know, thank you!

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

ok, in qjackctrl connections window there is nothing in the audio and out, and there is nothing available to select.
in the qjackctrl preferences window, at the "input" there is the possibility to choose between my HDA intel pc soundcard and my USB webcam. so, what shpuld i do? thanks
stefano

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

another hint: ardour does not seem to receive any audio from any input, BUT it does send audio out, even if there is nothing in the qjackctrl connections window audio in and audio out.

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

i'm sorry. i'm tatlly incompetent, but i need to make ardour work!!
this is the situation:
i start jack, and in the jack audio connection kit i find capture 1 and 2 in "out", and playback 1 and 2 in "in", with no connections made; in the preferences window, in input i can choos between my HDA intel soundcard and my webcam USB, but in no way am i able to get any sound be detected in ardour recordings!!!
instead, if i run audacity, i can record sound both from the line in and from the usb webcam.
why is that???

veda_sticks
User offline. Last seen 2 years 16 weeks ago. Offline
Joined: 2011-03-11
Posts:

with ardour open, create a new track, this should automatically route capture 1 and 2 to the inpyut of the track you just created, then click the arm buttom on the track (red circle) test your input, if nothing happens, look at jack connections to see if capture 1 and 2 have lines going to the right where ardour is. if not manually connect them the audio in.

to do this, click system under readable clients.output, now click capture_1, then on writeable clients/input ports ther should be ardour, click that

now a list of input ports ,, your track will look like audio in1 or somthing like that, click that and hit the cfonnect button.

dont forget you need to start the jack server and make sure that it is running, you can have gjackctrl open but the server not running. if its not running press start, and on the dispaly next to the buttons it should then say started, if you get errors you need to work out why jack cant start.

if jack is started and running fine, and your capture is routed to your audio inputs, and still nothing. your going to have to check that the system is set to use the right input if your card has multiple, normally this is automatically detected when you plug it in.

you'll need the alsa mixer, it should be called mixer and is usually under multimedia in your applications menu. with also mixer you can change which input is selected and also the volumes, this may need configured as when i first started it, there were no options.

veda_sticks
User offline. Last seen 2 years 16 weeks ago. Offline
Joined: 2011-03-11
Posts:

by the way ardour will run without jack, as it can run with the alsa driver, but i recomend using jack.

if you have jack open and go to connections and see nothing under the readable and writeable clients, jack is not running

paul
paul's picture
User offline. Last seen 8 hours 51 min ago. Offline
Joined: 2006-03-16
Posts:

"without jack" is not accurate.

"without qjackctl" is accurate. qjackctl is also called "Jack Control" on some platforms.

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

thanks veda_stick. i made all steps of the above, so now on my ardour track, capture1 is connected to audio in1 and capture 2 is connected to audio in2, jack is started, the system is set to line in and volume is sufficient, the proof is that with audacity the recording from line in works perfectly fine. but still i can not get any sound to reach my ardour recording track. why could it be so???

paul
paul's picture
User offline. Last seen 8 hours 51 min ago. Offline
Joined: 2006-03-16
Posts:

stefabarta: what test are you using to establish that no sound is getting into ardour?

veda_sticks
User offline. Last seen 2 years 16 weeks ago. Offline
Joined: 2011-03-11
Posts:

open up alsa mixer, i had this problem with line in not working for some unknow reason and i had to open alsa mixer and fiddle with a few things like setting it to line in, and making sure the capture slider was up.

try pluging into the mic input and see if you get a signal, if you do then its probably a setting in alsa mixer, like i had the same problem was getting it fine through the mic input but nothing in the line input until i played with alsa mixer

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

thanks paul and veda_stick! the problem was actually in the computer settings for receiving the line in. now the recording works fine! do you know if there is a way to save the jack connections from one ardour session to the next? thanks again

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

well, last recording session everything worked fine. but today i re-opened the ardour file, and even tried creating new ones, and again no sound is being detected while recording!!! checked all jacks connections settings, so the line in goes in the inputs of ardour track, then re-checked the selection of the inputs on the jack preferences, then checked the pc audio in settings, then checked the hardware through which the sound is produced. all steps seem to be verified. in the doubt that the line in of the pc might be suddenly broken, i tried making selections in jack preferences for my usb webcam instead, choosing it even in my pc audio in settings, but nothing comes out!! it makes me crazy, that means there is still a problem along the line that bring the sound to the ardour recording track, but i dont seem to be able to detect where it might be! help!!! thanks

paul
paul's picture
User offline. Last seen 8 hours 51 min ago. Offline
Joined: 2006-03-16
Posts:
stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

even if i re load a previously working adour session, this time, after i quit ardour and jackd, in the newly open session i was not able to get any sound. so i'm stuck again, without any hint what the problem might be. the only difference i noticed in the settings is that now in the setup window of jackctrl the "interface" is gone to "default" and that it does not let me select anything else since the command seems to be inactive. anyone can help me on this?

Pablo Fernández
User offline. Last seen 4 years 29 weeks ago. Offline
Joined: 2007-02-20
Posts:

now in the setup window of jackctrl the "interface" is gone to "default" and that it does not let me select anything else since the command seems to be inactive

Make sure you select the alsa driver (just above "Interface")

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

to pablo: alsa is selected, but still the interface command is inactive. why?

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

i start getting desperate. sometimes i get ardour to record properly, sometimes no sound reach the recording track of ardour, even in the same session that 1 minute before was working properly! it all seems to be random. i made a lot of cross-checks.
ok,these are all the checks i did:
jack started, jack connections, jack setup inputs, jack setup interface (it's not active, and is on "default"), hardware line in volume and muting, no other applications running (like skype, audacity).
result: random!!
please help with some ways i could get over this problem that is making any work with ardour impossible! thanks

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

following and correcting my last post:
i continued to make cross-checking and i discovered that it's not random behaviour, there is a pattern that is repeatable.
if i start my ubuntu , then start jack, then ardour (with all the checkings of my previous post), the result is i dont get any sound to reach ardour through my line in.
if i then quit ardour and jack, and then start audacity i record perfectly from my line in, then if i quit audacity and start again jack and ardour, ardour records perfectly fro my line in!
if i restart ubuntu and start again jack and ardour without having used audacity, ardour does not record anything!
i'm very surprised, but i'm now sure that it's working as i describe it.
this should make possible for expert people to detect why the audio does not get recorded in ardour under certain circumstances. thanks for any reply!!!

seablade
User offline. Last seen 2 hours 13 min ago. Offline
Joined: 2007-01-22
Posts:

It seems likely then that something is already using your device when you try to connect to it, and thus Jack is defaulting to a device not in use. Pulseaudio is usually a culprit for this.

Seablade

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

thanks, seablade.
so, why could it be that the interface command in jackctrl setup window is gone inactive?
and how can i detect in ubuntu which device is in use?
audio applications that i usually use beyond ardour are: movieplayer, rhythmbox, skype and audacity.
how can i detect what they are relying on?

veda_sticks
User offline. Last seen 2 years 16 weeks ago. Offline
Joined: 2011-03-11
Posts:

have you checked alsa mixer, i had this problem with it not autoselecting which input i had plugged into until looking at alsa mixer and setting it myself, now it does it own its own.

stefabarta
User offline. Last seen 1 year 41 weeks ago. Offline
Joined: 2011-01-27
Posts:

to veda_sticks: i don't have an idiea on how to do the alsa mixer check. i work on ubuntu. can you suggest the steps necessary to do that check? thx

anahata
anahata's picture
User offline. Last seen 12 hours 47 sec ago. Offline
Joined: 2010-10-27
Posts:

I don't know if this helps, but I have Ardour set up to start Jack - I only have to run Qjackctl to start Jack on the rare occasions when I need Jack for something else, usually simple routing of an input to an output to test a mic or cable.

Once I got my sound cards in the right order (ALSA was trying to use the onboard sound instead of the M-Audio Delta 1010) this arrangement has been quite trouble free.

Oh, and I concur that PulseAudio is a bag of problems. On another system, removing PulseAudio was the only way I could make any audio work at all.

veda_sticks
User offline. Last seen 2 years 16 weeks ago. Offline
Joined: 2011-03-11
Posts:

I use ubuntu aswell, it should be in multimedia, along with all your other audio programs like ardour and jack control. It will either just say mixer, or alsa mixer. when you open it up. there will likely be no controls so you will have to select the controls you want to appear in the mixer.

The program when opn up with say mxier - HDA nvidia (alsa mixer) : note that hda nivida is my sound interface yours will probably be different.

I selected from the list

Master
Line In
Capture
Capture 1
Automute mode
Input source 1
Inpute source 2

what you can select might be different. will depend on yoru hardward

But under input source is where you can select the input.

Capture is the volume for the input source (capture 1 on mine doesnt seem to do anything)

and there is an option for automode, which i believe should automaitcally switch between mic and line when you plug in.

im running xfce desktop enviroment

WillStewart
User offline. Last seen 2 years 4 weeks ago. Offline
Joined: 2015-06-15
Posts:

I'm having a similar problem on one laptop in Ubuntu Studio. Have used Audacity, where my mic works fine, and have used a mic on another computer in Ardour3 with no issue. However, on my Dell LatitudeD630 laptop with SigmaTel STAC9205 soundcard, the mic does not work on Ardour3. I've set up the correct jack connections from capture 1 to the audio track to the master (much more basic that other configurations I've used on my other computer). I can import and play .wav files, so that aspect of Ardour is working with the soundcard.

Any suggestions?

seablade
User offline. Last seen 2 hours 13 min ago. Offline
Joined: 2007-01-22
Posts:

@WillStewart

It sounds like you are using a built in sound card? Have you checked the alsamixer, or equivalent for your card to make sure that there is no switch that needs to be set for a mic input, and that the gain is set appropriately? Are you certain that this sound card is not presented as two half duplex devices(Sadly increasingly common) and that you have the correct device selected in that case?

Seablade

WillStewart
User offline. Last seen 2 years 4 weeks ago. Offline
Joined: 2015-06-15
Posts:

Thanks, seablade, I rechecked Gnome Alsa Mixer, and then 'jiggled' a number of other settings. After doing this twice and rebooting, it now works (!). Thanks for jumping in and helping. cheers.

WillStewart
User offline. Last seen 2 years 4 weeks ago. Offline
Joined: 2015-06-15
Posts:

Thanks, Seablade, I had used Gnome Alsa Mixer to check settings, though your suggestion motivated me do a little more deeper looking and tinkering. After 2 more reboots with said tinkering in-between, it now works. Interestingly, the first use I'm putting this laptop to is to utilize the echo to acclimate my daughter's singing group to stadium echoes as they are performing the National Anthem for the Washington Nationals later this week.

cdiddy79
User offline. Last seen 10 weeks 2 hours ago. Offline
Joined: 2017-09-11
Posts:

two to four years later... will anyone see this? I am just getting started with music in Linux. Have my RayDAT set up, HDSPMixer shows levels coming in, JACK control shows captures linked to Ardour tracks... tracks are armed to record, but meters show nothing. Recording produces blank tracks. Googleing and reading forums all night, and no progress.... anyone care to offer advice?