Plugins Crackling

5 replies [Last post]
EvilPowerMaster
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2007-02-02
Posts:

I've been playing with Ardour on OSX for a while now, and I've been pretty happy, once I got a few details worked out.

One problem I have right now is that whenever I have any plugins running, they generate crackles and pops during playback, and even on export.

I don't think its taxing my system that badly, since Ardour itself is only showing a DPS load of usually around 5%, and Jack is rarely above 10% CPU load. According to top (or Activity Monitor if you prefer the GUI tool), Ardour usually uses abotu 18% CPU during playback.

Those numbers only dip marginally when I disable all my plugins, but all the crackling goes away. Turn any of the plugins on again? The crackle comes back.

I don't know what else to look at - am I missing something?

Jack settings: Sample rate at 44.1, buffer size is 512.

Any idea as to what I should be looking at?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Which plugins are you running?

Btw. top is not a good measurement for DSP power. Top tells you how much processing power there is left on average. Ardours' DSP percentage tries to show you how much processor time there is left to reach the realtime deadline. It is a far more accurate meter for how much "DSP" load your system can take.

Reuben
User offline. Last seen 4 years 32 weeks ago. Offline
Joined: 2006-03-30
Posts:

Are any of the settings on the plugins automated? There are many plugins that are not anti-aliased, so they snap crackle and pop when you automate them.

Sometimes overly agressive settings when compiling also cause problems with the floating point calculations, resulting in cracking sounds (or worse).

EvilPowerMaster
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2007-02-02
Posts:

Sorry I've taken so long to respond, been a busy week.

I have all the plugins that are linked on the site installed (SWH, TAP, CMT and CAPS), so I'm not sure which plugin came from which set.

Right now, all I'm using is the DJ EQ and the Fast Overdrive, and they still crackle sometimes. They're not as bad as some others that are a bit more DSP intensive, but a simple EQ and an overdrive (both of which CAN be automated, but I'm not automating anything right now) don't seem like they should be causing this much of a problem.

I've seen this problem with the TAP EQ as well, and a couple others, that I can't find right now. I also seem to have this problem with any compressor I try.

I should probably have included this initially, but my setup is like so;

10.4.8
Ardour 0.9.33
Latest version of JackOSX (0.74 - JACK Version 0.101.3, Jack Router Version 0.8.3)
G4 Powerbook, 1.67GHz
1.5GB RAM
Presonus Firepod

bbain
User offline. Last seen 5 years 2 weeks ago. Offline
Joined: 2007-01-07
Posts:

Have you tried Ardour2?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Do the crackles coincide with xruns? At what buffer size, number of periods and on which sound card are you running jack at?