Soundfile Library: can't add more directories/files/folders

4 replies [Last post]
NOYX
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2007-02-05
Posts:

for some reason, after importing some directories, i can no longer add more to the library list. is there a limit to the # of files that can be accessed in the library?
i am using 64studio - ardour 0.99.3
thanx in advance

taybin
User offline. Last seen 40 weeks 6 days ago. Offline
Joined: 2006-03-15
Posts:

There is no hard limit in the code. If there are too many it will slow down, but not fail to import them. Does it give an error message? Perhaps one of the files has a parculiar spelling that is messing it up?

NOYX
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2007-02-05
Posts:

nope, no error message- just wont show the rest of the folders/directories.
does this have anything to do with non-audio files within the folders?

i read an issue ticket with a similar experience [ id 0000660 ].
at first, i was trying to add the whole folder which contained ~7/8 subfolders of organized soundfiles, and had the same issue of scanning/loading. could see the directories being added, and then at a certain point, underneath the main folder went all 'black'[empty] like nothing was there, only the folder name with +/- for expanding. so i attempted just adding the [7/8]subfolders instead. 4 showed up fine, but after that, it wouldn't visualize any others that were added-it was blank underneath the 4th folder- ? - there are other types of files within those folders other than wavs, so maybe that has something to do with it?

NOYX
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2007-02-05
Posts:

ok, so i copied that [library_ui.diff] file to the .ardour folder in /home and that seems to have taken care of it. sorry, but i wasn't sure what "apply the file to ardour" meant in your response to the issue ticket. if that wasn't the correct thing to do, then it just works now. updating all the packeges must have helped.
thanx for your time-sorry for being so quick to post about this issue.

NOYX
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2007-02-05
Posts:

hmm wierd-nevermind; next time i opened ardour and went to the library, only the main folder showed up, after removing it, and re-importing, it all appeared.- ? sorry for being a bother