Real time for the current user

5 replies [Last post]
gosvald
User offline. Last seen 3 weeks 5 days ago. Offline
Joined: 2013-05-13
Posts:

I had to recently re-install the system due to some complications. When installing ardour I got this message again: "System does not allow realtime for the current user"
I remember that when I got it previously, I found some instructions somewhere on the net how to fix this. I created a group, ran some commands.....can't remember. Anyone has a clue where I could have seen this information?

gosvald
User offline. Last seen 3 weeks 5 days ago. Offline
Joined: 2013-05-13
Posts:

Never mind...found it.

rombus
rombus's picture
User offline. Last seen 18 weeks 22 hours ago. Offline
Joined: 2011-12-22
Posts:

Hi, you should post what you did so that someone with the same problem can figure it out. And also for you in the future. Cheers

dbra
User offline. Last seen 3 hours 50 min ago. Offline
Joined: 2012-12-27
Posts:

And the used distro is also very important.

MAD_sick
User offline. Last seen 1 week 1 day ago. Offline
Joined: 2013-03-24
Posts:

On Ubuntu:
JACK server must be installed with "realtime" settings. Run
sudo apt-get install jackd qjackctl
to install it. You will be promted about realtime during itallation process.
After that, run
sudo gedit /etc/security/limits.conf
& paste
@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19

in the end of file. Next step is adding you into "audio" group.
sudo gpasswd -a username audio
It needs restart or re-login.
And dont forget to check parameters in Qjackqtl. "Realtime" must be on its place.
Sorry for English.

paul
paul's picture
User offline. Last seen 1 day 4 hours ago. Offline
Joined: 2006-03-16
Posts:

To repeat for the N-teenth time, the "nice" line has no place in any RT audio setup. This is a myth that started years ago outside of the JACK community, and is not true, is misleading and unnecessary. The "rtprio" and "memlock" are the ones needed, nothing else. This is covered in the JACK FAQ.