Hi, new user (both ardour & linux) saying hello and asking a few questions;-)

2 replies [Last post]
funkster1
User offline. Last seen 4 years 17 weeks ago. Offline
Joined: 2007-02-11
Posts:

Ok people, hello to all of you.
It just seems that I have entered a wonderful world and many new ways to explore my Audio/MIDI adventures.
A very, very big 'thank you' to all those devs out there for making such wonderful tools and sharing them with the world.
I've decided to kick $MS in their rear and change OS completely.
Not a trivial task by any means, but I'll do anything I need to make the transition possible.
So I discovered a few music distros like 64 Studio/STG, Musix, DeMuDi etc, and while things seem to work (more or less) from those LiveCD's, it's still quite different from installing to HDD.
Now I'm trying out FedoraCore5 with the Planet CCRMA additions, as I found 64 Studio somehow limited and difficult (if not impossible) to install additional software.
FC5 installed OK, no probs, did all the updates, installed all the packages from CCRMA (incl.the 2 'old'_new kernels) and now I'm sitting here, trying to record some stuff.

There seems to be a problem either with jackctrl, my soundcard driver (Delta 101LT with Alsa and Envy24 mixer) or whatever, but after a while (20-30 min.) the sound gets somehow garbled/distorted. Kinda like some broken cables if you know what I mean. Only a reboot of th PC can set this straight. Not nice.

Then there seems to be a little bug/problem with Ardour: while connecting I/O's from the Mixer view, often Ardour (.99.3.8) just vanishes the moment I add or remove an I/O.
Now I don't know anything about Linux and it's inner workings. I have only started to use PC's maybe 5 years ago, and only now did I become comfy with those Win machines. This is, I can now individually tune a PC for certain tasks and tweak the hell out of it. My WinXP DAW runs quite fast for what is now considered an old PC I guess (AMD 2000+ T-Bred). Details are in my sig. anyway.

Then comes the inevitable question of how to use my VST plugins. The fst website seems to be gone, so I don't know where to gather info or even the fst package (if it's available at all for Fedora).
So, if any kind soul could provide me with some info or help, that would be really nice.

Be sure to see me asking a truckload of other questions soon. There's just soooo much to learn.

Best regards
Raphael ;)

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

That sound problem sounds very bad. Do you have any SPDIF cables attached to the soundcard? It somehow sounds a bit like a sync issue.

You probably can get out of the garbled/distorted state by unloading the sound driver and loading it back in - but that's quite a lot of hassle. I suggest you post that question on the linux-audio-user mailing list. There are a lot of people reading the list who are active and know about these sorts of things. I do suggest asking only one question at a time when posting there.

Regarding I/O:s, I don't quite grok what you mean exactly. Does this happen when you connect track/bus inputs/outputs via the "context menu" or the "I/O dialog"? Is this a problem with changing the number of inputs or outputs, or is this a problem with connecting something to these inputs or outputs?

Then the last bit about VST's. It does seem like the FST page has vanished. If you use Ardour though, you probably would want to use Ardour with "native" VST support anyhow. To do this, you must compile Ardour yourself as it is impossible for us to distribute Ardour with the required VST development kit files. Alas, this makes it illegal for anyone to distribute Ardour binaries with VST support. Ardour uses an internal version of FST for VST support, so all plugins which work with FST work with Ardour and vice versa.

Do not get your hopes too high though: Not all plugins work. This incompatibility is caused by: a) wine incompatibility problems, and b) bad plugins.

a) Whenever a new version of Wine is released, it might make some plugins work but it might also break a few which used to work. Things starting to work is due to fixes in wine and things breaking will be inevitably caused by breakage in wine OR bad plugins.

b) The quality of some VST plugins is abysmal. There are a huge number of plugin writers out there who have ideas in their head but not enough knowledge / skill. The "almost free" world of free VST plugins knows no such thing as peer review - free VST plugins are riddled with non realtime-safe code. Not being realtime safe will lead to big problems. Not even all the commercial VST plugins are free of these issues.

VST plugins will work for you if you test the plugins you will use very well before trusting them in real-world use and be very wary of updating wine.

funkster1
User offline. Last seen 4 years 17 weeks ago. Offline
Joined: 2007-02-11
Posts:

Hi Sampo,
thanks for offering your help.
OK, I have updated Ardour & Jack (there were new packages in the planet ccrma repo it seems) and I think Alsa has had a revamp as well. I've played around with ardour and hydrogen for about 2 hours now without a hickup. That sound problem is surely not a sync thingie (don't think so) I have nothing connected on S/PDIF. Maybe it has to do with ACPI/APIC support/settings, because since a few weeks I have a severe hardware problem (my mainboard not wanting to run in APIC mode anymore, though it has been fine with it enebled the last three years). I think that it is a short somewhere on the circuit. I can fiddle with the mobo in the open case, and suddenly I push the floppy cable or anything else, this bloody machine boots. What gives? Windows would freeze the PC within 15 min. max.
64 Studio didn't freeze only one time. But I had Grub configured for 'acpi=off noapic noapm'. Now Fedora on the other side with the realtime kernel from ccrma seems a bit more picky about this. I have temporarily enabled acpi & apm again and like I said, no problem for the last 2 hours or so.

The bit with the I/O dialog crashing, yes, it's the box that pops up when you click on the In or Out button of a channel strip. Sometimes when trying to add or remove an In- or Output, ardour goes 'pouf'.

As far as VST goes, well, I have some money invested in commercial plugins, and it would be sad not to use them anymore. Some of them I could resale, I know that some of the devs allow for license transfert, others not really.
And compiling ardour myself, well, I'll leave that for another time I think. It's all too new for me. I first need a fair understanding of the underlying OS before I go building my own apps. I'm certainly not afraid of trying things out, but when you reinstall your backup image the 4th or 5th time a day because you've tweaked some stuff you shouldn't touch, well....

I have looked around a bit on the net, and it seems there are quite a few quality plugs out there, just not too many synths it seems. Though I've discovered Bristol and will try to compile the package :D
They sure do LOOK nice. If they sound half as good as they look, well...

Anyway, thanks for stepping by

Regards
Raphael ;)