problems installing ardour from the ground up

7 replies [Last post]
duojet
User offline. Last seen 7 years 8 weeks ago. Offline
Joined: 2007-02-24
Posts:

I would really appreciate it if anyone here could help me..

I've been using Kubuntu Dapper for the better part of a year now, and only using windblows for my music. I HATE doing it that way, but at least it works.

I finally decided to chuck win completely, but I'm having a hard time doing it.
I'm using a Dell dimension 4400 p4 1.7 768mb ram
the sound card is a Turtle Beach Santa Cruz (cs46xx crystal sound chipset) and Kubuntu Dapper has been installed.
I followed the steps in the ubuntu studio wiki, and now when i try to use ardour, I can record tracks from Hydrogen, and play them back with sound.

What I can't do is get ANY sound recorded from the mic or line inputs. I get signal in my monitors, but none on Ardour's meters. When I try to configure jack, it gives me hw0 and hw0,0 as capture devices. Neither of these seems to make a difference. Ardour pretends to see inputs but selecting them is useless.

what is going on?
would i need a different sound card to use ardour?
which one(s)?
do I just need to manually configure or download a driver?
Is there a better distro that would be easier to use (aside from Jack Open SuSe, Musix, DyneBolic, or Ubuntu Edgy which have all had the same problems or worse)?

I'm TOTALLY WILLING to just wipe the hard drive and start again, if I can find a clear set of instructions. Every Walkthrough or Faq i have seen is incomplete for my particlar needs.

I would love to show my friends how to record with linux, as that is the only reason why they are still using ms. Right now I'm just about ready to suck it up and go back to cooledit.

philicorda
User offline. Last seen 1 year 46 weeks ago. Offline
Joined: 2006-05-16
Posts:

There might be a problem in the mixer settings.
Try plugging a test signal into your sound cards line input.
Then start alsa mixer, press 'tab' to get the capture settings, and turn up the mixer elements until you see a signal on a record enabled track in Ardour.

Another thing to try is to record a track in Ardour, even if there is no signal apparently going into it.
Then, normalise the recorded track. If you see some hiss then it's a mixer setting/analog problem. If you see a flat line then Ardour is not seeing the sound card at all and you need to check the jack configuration.

duojet
User offline. Last seen 7 years 8 weeks ago. Offline
Joined: 2007-02-24
Posts:

well, I've been using alsamixergui, and I've got LINE and LINE1 so hot the signal breaks up in my speakers. The controls seem to work (when I turn the channel off, the signal through the speakers stops, when I turn it back on the volume works).

just because I'm willing to try anything at this point, I opened Alsamixer in konsole. When I hit Tab for capture settings, I see LINE and MIC in dark red, and they don't have any volume controls...

sampo
User offline. Last seen 11 weeks 1 day ago. Offline
Joined: 2006-03-16
Posts:

"Capturing" audio is totally separate from what is routed straight from the inputs to the outputs.

See the section about "consumer" soundcards in the manual: http://www.ardour.org/files/manual/sn-monitoring.html

duojet
User offline. Last seen 7 years 8 weeks ago. Offline
Joined: 2007-02-24
Posts:

If I may sum up the relevant part of the article, it seems to say that because hardware mixers in consumer cards have little to no orthodoxy, it is difficult to find a common solution, if any.

I kind of knew that. sorry if I seem testy, but I'm a bit frustrated. I was hoping somebody had experience with my particular soundcard.

Since it looks like I can't make this work, is there a consumer level card that is fairly reliable? anyone? (maybe I should post that to a new thread) I've been able to use cooledit with no problem as well as acid, but I'd rather not go back to windows unless someone tells me I need a $200 soundcard.

-not that I'd never spend $200 on my music, I'm just not quixotic enough to spend it on my desire to fully migrate from windows.

nowhiskey
User offline. Last seen 5 weeks 12 hours ago. Offline
Joined: 2006-09-30
Posts:

hi,
i am not sure about your onboard sound, but as i know, if that card is supported by alsa, than for sure you should be able to use it with ardour.
try opening alsamixer, than press "h" it will show you all available commands. pressing "return" will give you the main page again.
than pres "tab" to come to the "capture" part, with "left/right arrow" navigate to mic or line in, what ever you wont to capture from. if you pres "space" now, the device will be enabled for recording. now you have to navigate to "capture" and open up "the slider" to perhaps 70%.
that should work, i hope!

cheers,
doc

duojet
User offline. Last seen 7 years 8 weeks ago. Offline
Joined: 2007-02-24
Posts:

THANK YOU! that did it!

I went through and dimed everything and just turned them on.. the problem was that for some reason the ADC (analog to digital converter?) was turned OFF by default (go figure). And of course things got interesting when I enabled the DAC as a capture device. I didn't know that a soundcard could self oscillate, but oh yes it can (sounds like a robot torture chamber).

I must have read at least 20+ pages of docs on this subject over the last few days and I never ran into this advice THANK YOU THANK YOU THANK YOU!

nowhiskey
User offline. Last seen 5 weeks 12 hours ago. Offline
Joined: 2006-09-30
Posts:

nada!
a year ago i went into troubles unmuting something in my alsymixer, what
resulted in no having any sound on onboard for a month!
so i went to the alsa mailinglist and lot of people trying to help me, but
we was not successfully for long, already thinking that the onboard sound
device is damaged somehow, until i muted some stuff in the right order
again, so it worked than!
alsamixer is powerful but pretty special.

cheers,
doc