going out of my mind - usb, jack, and ardour

7 replies [Last post]
clinart
User offline. Last seen 7 years 5 days ago. Offline
Joined: 2007-02-23
Posts:

I sure hope someone can help because I've looked high and low for an answer and can't find it.

I can't capture my guitar through my M-Audio MobilePre usb card. Yes, the mixer settings are right -- capture 1 is turned up. Yes, there is a signal. Yes, I can hear the sound. Yes, the patchbay shows the card connected to Ardour. Yes, the track that should be taking the guitar is set to record from input 1, which is connected to alsa_pcm capture 1. Yes, inputs from other programs work on other tracks. No, nothing is muted.

Still, no signal when I hit record. The thing that's driving me crazy is that I had it working a couple days ago.

Any ideas?

clinart
User offline. Last seen 7 years 5 days ago. Offline
Joined: 2007-02-23
Posts:

OK, got it.

Multiple soundcards are a pain in the behind with Linux. For some reason, the hw:x designations change every time I reboot. In the above case, the interface device in the JACK settings was somehow set to the onboard sound card. A third soundcard complicates things considerably.

Anybody know a good way to prevent these devices from re-indexing themselves seemingly at random?

paul
paul's picture
User offline. Last seen 11 hours 16 min ago. Offline
Joined: 2006-03-16
Posts:

there is an argument for every snd-* module called "index" which can be provided to lock down the card number it gets (you can provide a comma separated list if you have more than 1 of the same type of card).

where to add this is, unfortunately, a distro-dependent thing.

clinart
User offline. Last seen 7 years 5 days ago. Offline
Joined: 2007-02-23
Posts:

I'm on FC6. Do you happen to know what I need to edit?

Thanks.

Oh, by the way, the results of the first guitar recording session in Ardour are here if anybody's interested. Got a little interference from the Internet in the first ten seconds, but it sounds pretty decent.

paul
paul's picture
User offline. Last seen 11 hours 16 min ago. Offline
Joined: 2006-03-16
Posts:

FC6: you need to edit /etc/modprobe.conf, and make it contain lines a bit like this:

alias snd-card-1 snd-hdsp
options snd-card-1 index=1
options snd-hdsp index=1
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0

for you, the modules will likely differ. you could also try running alsaconf and see what it comes up with.

clinart
User offline. Last seen 7 years 5 days ago. Offline
Joined: 2007-02-23
Posts:

Yeah, my modules are different and I have three cards, but I see what needs to be done. Thanks again!

mridlen
User offline. Last seen 6 years 45 weeks ago. Offline
Joined: 2007-06-07
Posts:

I have the same soundcard, and I'm having the same problem (I think), but with Ubuntu instead. I open alsa mixer and it sees it as something like "Mobilepre (alsa)", and I can open sound settings and set my sound devices to something like USB and get a test tone out of it. I can even open Audacity and XMMS and get sound out of both of those. Heck, I can even record in Audacity by setting my recording device to hw:1,0. But my problem is that Jack is only seeing two channels of input from alsa, and it's the onboard stereo input. I would really appreciate any help on the matter.

EDIT: It looks like this is an issue with jack -> http://www.ubustu.com/globe/2007/05/29/how-to-configure-jack-in-ubuntu-studio/

I'll try that when I get off work.

EDIT: Nevermind, that solved my problem. I ended up having to set the device in JACK control to hw:1,0 and set the input and outputs both to hw:1,0. Looks like the issue has been resolved for me. Now I just need to learn Ardour :-P

chamcham
User offline. Last seen 4 years 45 weeks ago. Offline
Joined: 2007-03-09
Posts:

I posted a link to a great Ardour tutorial here:

http://ardour.org/node/1376