stop Ardour from autoconnecting

3 replies [Last post]
oNNogitaar
oNNogitaar's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2011-03-29
Posts:

Dear all,
Ardour keeps making connections i do not wish to have.
Currently i am on KXstudio12.4.3

under edit>preferencies>audio i unticked ¨Auto-connect master/monitor busses¨ and for ¨Connect track inputs¨ and ¨Connect track and bus outputs¨ i selected ¨manually¨. Still if i close and reopen Ardour the click is connected to 1&2 automatically... How can i fix that?

Also i tried (in Claudia)¨Save studio¨, reopen Ardour and ¨Load studio¨ but then Ardour says ¨The audio backend was shutdown because: Jack server has been closed.¨

There is probably a wiki or so about it but i have not found it...
Thank you!

paul
paul's picture
User offline. Last seen 12 hours 27 min ago. Offline
Joined: 2006-03-16
Posts:

you could try starting it on the command line with -P:

-P, --no-connect-ports Do not connect any ports at startup

Not sure how well it works. Your message about the audio backend shutdown means either that Ardour was too slow and JACK kicked it out, or that JACK did in fact die.

oNNogitaar
oNNogitaar's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2011-03-29
Posts:

hmm, so there is no option to be switched off?
I do not remember this behaviour from Ardour2
I have select these output (in Ardour2) here: window->Preferences->Click and opened the file in Ardour3.
But in 3 one cannot set the output for the click in: Edit->Preferences->Misc
Probably there is this old setting lurking around? (the tracks are still called: click/audio_out1&2)

I tried removing the connections 1&2 in Window>Audio-connections, closed and reopened Ardour and the connection to 1&2 was there again. So i gave up :)
This morning i reopend ardour and... the connection to 1&2 was gone.
Shoot me :-p

¨you could try starting it on the command line with -P¨
that would be: ardour3 -P right?
But than i would have to manually reconnect everytime i start Ardour...

Thanks!

oNNogitaar
oNNogitaar's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2011-03-29
Posts:

it looks as it has cured itself.
Probably it did not save properly.