No audio output

3 replies [Last post]
taoleo
User offline. Last seen 19 weeks 5 days ago. Offline
Joined: 2013-11-03
Posts:

Hi,
I am new to recording...
I was unable to find an answer from searching which surprised me as I figured this would be a common problem.

While working on a recording I received the message;
'Jack has been shut down or it disconnected Ardour because Jack was not fast enough. Try to restart Jack, Reconnect and save session.'

I did as suggested and Jack is reconnected, however there is no sound output. At first there was not a output level reading on the Master channel though I was able to fix this by editing the Master input choices. Now I have the output levels back on the Master channel but still no audio output.

The audio output is fine on other recordings and other audio files so the damage must be limited to just the recording I was playing with before I got the message.

I have tried and cannot fix due to inexperience it so I write to this forum to seek advice.

Also, I tried to use the .bak file however I was unable to open it, how can I open this file?

Cheers
Nigel

veda_sticks
User offline. Last seen 13 hours 40 min ago. Offline
Joined: 2011-03-11
Posts:

This sounds more than likely just a routing problem, though i find it unusuall that ardour has not restored all connections properly. Normally if i shutdown jack while ardour is still open say to change a setting, and start jack back up, once i reconnect all the connections are restored as they were.

check that your master bus outputs are connected to the right playback channels. If you have a surround sound output you will have multiple outs. Mine has 8 outputs. Usually stereo out is playback 1 and 2, but sometimes its not, you can go through them untill you get the right outputs.

In the mixer, on the bottom of the master channel there is a box which you can click and will bring up ardours patch pay.

taoleo
User offline. Last seen 19 weeks 5 days ago. Offline
Joined: 2013-11-03
Posts:

veda-sticks,
As you suggested the problem was in the Master channel patch bay.
Many thanks...

Smeefer
User offline. Last seen 8 weeks 1 day ago. Offline
Joined: 2011-05-11
Posts:

taoleo, I have an additional suggestion for preventing the "Jack shut down" error in the future: go to your Jack Setup - do you have "Realtime" checked? Check it if not. Is the "Priority" turned up? I have mine at 80. The Frames/Period, Sample Rate, Periods/Buffer settings will affect latency and potential Jack shut downs. Try to find a balance so that you have low latency and at the same time, Jack doesn't shut down on you. Turning up the "Timeout (msec)" setting can help as well. What is your latency?

I'm using a Focusrite Scarlett 2i2 usb soundcard and I have these settings, which work great for me: Frames/Period 1024, Sample Rate 9600, Periods Buffer 2. My latency is 21.3 msec and Jack never shuts down. If you're also using a soundcard that allows 48k or 96k sample rates with 24 or 32bit format, then definitely try settings like mine and you should be golden.

Also keep in mind that when using Ardour, the more LV2/LADSPA/VST plugins that you're using at once, the more likely Jack will shut down. Try minimizing the amount you're using at once. I like to figure out the perfect settings for plugin effects, then export the individual track without the plugin effect (just for a backup), then record the audio with the plugin effects onto a different track, then delete the original track and the plugins. This helps minimize the amount of memory or processing power that I'm using at one time and helps prevent Jack shut downs or other software crashes, etc problems. Cheers.