libjack0.100.0-dev won't install

2 replies [Last post]
cmurphy
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2007-03-13
Posts:

I'm doing my own build with scons. I have downloaded all the needed dependencies except for one: libjack0.100.0-dev.

I can't get the development package ,libjack0.100.0-dev version 0.101.1.1-2 to install, since I have libjack0.100.0-0 version 0.102.20-1 installed. I get the following error:
libjack0.100.0-dev: Depends: libjack0.100.0-0 (= 0.101.1-2) but 0.102.20-1 is to be installed.

I thought about just uninstalling version 0.102.20-1 and then installing version 0.101.1. However, when I go to uninstall it gives me a message that just about all of my audio programs will be uninstalled. That wouldn't be good. Anyhow, sorry if this has already been addressed somewhere. I googled it and searched this forum but didn't see anything.

I appreciate any help. Great software by the way, I love 0.99, and am looking forward to trying out 2.0.

Thanks,
Chad

cmurphy
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2007-03-13
Posts:

Okay, I did more searching and I found this: http://64studio.com/ticket/267. By the way I have the Studio 64 distribution.

We have shipped libjack 0.102.20 but Debian's libjack-dev is 0.101.1 which causes problems for people trying to build Jack applications from source. We should provide a matching libjack-dev 0.102.20 from our own apt source, and also encourage Debian to update.

So I downloaded the packages they have, and had to uninstall the packages I had. Which made all my audio programs go away. Oh well. I just finished running scons and it looks like ardour2 compiled. There are no errors. Now I just need to figure out how to get it started. :)

cmurphy
User offline. Last seen 6 years 1 week ago. Offline
Joined: 2007-03-13
Posts:

Oh yeah, "scons install". This is the first package I've ever built in Linux. I usually just use Debian packages. I figured I'd put this here, in case anyone else runs into the same problems. By the way I'm running Echo Layla24 (works awesome), Studio 64, on an Intel Pentium D (64-bit) Dual-Core 3.0 Ghz, 2 Gig's of RAM.

I was a big time Cool Edit Pro user (now Adobe Audition), and I needed a replacement as that computer fried (after over 5 years of running perfectly, and it was a Windows 2000 Professional box). I can't afford to get all the programs I lost, I don't even know where I put my install disks, and I'm not wanting to reinstall Windows 2000, so here I am. I've been really impressed with open source programs like Blender, so to finally see a nice DAW come along is just awesome! Ardour along with Jack and all the great plug-ins seems to be a good solution.

I'll let you all know how it goes.