Error while compiling Ardour3.5.143

7 replies [Last post]
MCLavyal
MCLavyal's picture
User offline. Last seen 12 weeks 5 hours ago. Offline
Joined: 2013-10-21
Posts:

While compiling it making the error
...
[497/804] subst: libs/plugins/reasonablesynth.lv2/reasonablesynth.ttl.in -> build/libs/LV2/reasonablesynth.lv2/reasonablesynth.ttl
[498/804] c: libs/plugins/reasonablesynth.lv2/lv2.c -> build/libs/plugins/reasonablesynth.lv2/lv2.c.3.o
../libs/plugins/reasonablesynth.lv2/lv2.c:60:3: error: unknown type name ‘bool’
../libs/plugins/reasonablesynth.lv2/lv2.c: In function ‘instantiate’:
../libs/plugins/reasonablesynth.lv2/lv2.c:110:18: error: ‘true’ undeclared (first use in this function)
../libs/plugins/reasonablesynth.lv2/lv2.c:110:18: note: each undeclared identifier is reported only once for each function it appears in
Waf: Leaving directory `/home/mclavyal/Downloads/Ardour3-3.5.143/build'
Build failed
-> task in 'reasonablesynth' failed (exit status 1):
{task 31310032: c lv2.c -> lv2.c.3.o}
...
Although the compilation succeeds the previous version 3.5.74. Im using Mint14 64-bit. what is the cause of this problem?

cajmere
User offline. Last seen 2 hours 21 min ago. Offline
Joined: 2009-04-30
Posts:

i've just build 3.5.184 , from git, and have no troubles with it.

Have you installed al the lv2 libraries and development packages?

MCLavyal
MCLavyal's picture
User offline. Last seen 12 weeks 5 hours ago. Offline
Joined: 2013-10-21
Posts:

mmm...yep, when configuring:
Checking for 'lv2' >= 1.0.15 : not found
Checking for 'lilv-0' >= 0.15.0 : not found
I have install all lv2.dev packeges with synaptic, and have no idea, how to get those packs of missing versions.

LeatusPenguin
User offline. Last seen 3 days 9 hours ago. Offline
Joined: 2010-12-16
Posts:

Have you tried looking for missing packages with "lib" in front of their names? For example, if you can't find lilv in synaptic, try liblilv.

MCLavyal
MCLavyal's picture
User offline. Last seen 12 weeks 5 hours ago. Offline
Joined: 2013-10-21
Posts:

Yes, they are all installed. but their version are 1.0.14 and 0.14.0

MCLavyal
MCLavyal's picture
User offline. Last seen 12 weeks 5 hours ago. Offline
Joined: 2013-10-21
Posts:

Checking for 'lv2' >= 1.0.0 : yes
Checking for 'lv2' >= 1.0.15 : not found
Checking for 'lilv-0' >= 0.14.0 : yes
Checking for 'lilv-0' >= 0.15.0 : not found

LeatusPenguin
User offline. Last seen 3 days 9 hours ago. Offline
Joined: 2010-12-16
Posts:

Ah ok, I understand you now. Short of compiling them yourself, you could try adding KXStudio's repositories which should have up to date versions of them.

MCLavyal
MCLavyal's picture
User offline. Last seen 12 weeks 5 hours ago. Offline
Joined: 2013-10-21
Posts:

Right! It work!) still not found lilv-0 (0.15.0), but compiled seccessful. Thanks a lot!