Click track is recorded onto track 1

3 replies [Last post]
jbrid
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2014-04-03
Posts:

Hi,
I can't figure out why the click track is being recorded onto my track.

I have checked the JACK connections. The 'Click/audio_out 1' and 'Click/audio_out 2' are mapped to 'playback_1' and 'playback_2' respectively. To me, that means that the click is sent back out to the USB interface as i would expect/desire. But instead it is being recorded onto the track.

To clarify what I am doing: 1) enable audio click 2) record a track 3) disable audio click 4) playback the recorded track. When doing so I hear the click track that I just disabled.

I have also done various tests to ensure that it isn't bleeding onto the track through my headphones or something. I am sure that it is being sent to Track 1 for some reason.

I also checked the patchbay through Window -> Track and Buses. In there the 'click out' under Ardour Misc is not mapped. Again, this is what I would expect, and that it would default to the mappings in JACK.

Any help is appreciated. Thanks!

paul
paul's picture
User offline. Last seen 1 hour 54 min ago. Offline
Joined: 2006-03-16
Posts:

Typically caused by the settings for the h/w mixer in the audio interface. Check the capture source - it can be set to record the playback signal. You don't want this - it should be set to one or more of the actual physical inputs.

You can test this by running a separate (jack-capable or jack-routed) audio app while ardour is running. You will probably find that whatever the other application plays also shows up on the input to the track.

jbrid
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2014-04-03
Posts:

Thanks Paul. I am sure you are right.
I have found that it happens with any track, not only the click track. Basically, subsequent tracks always get the master mix recorded onto them. Hence, making it impossible to keep tracks isolated. :(
I am investigating the options on the console now. When I record the second track, I want to monitor (via headpones) both the master mix that is coming from Ardour + my current track. I think that is where the issue lies, but that must be possible. I am using a ZED60-14FX.
uuuugh!
Thanks again.

jbrid
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2014-04-03
Posts:

Not that is has anything to do with Ardour, but in case someone finds this thread...
One solution is to use the 'Record Bus' option on the Zed console. That way it doesn't keep recording the main mix.
In hindsight, that should have been obvious. Oh well...