Loosing audio files

7 replies [Last post]
raptor59
User offline. Last seen 1 year 6 days ago. Offline
Joined: 2014-03-29
Posts:

Hi,

what am I doing wrong in this:

1) import audio file,
2) move imported audio file to another audio track (yes, i need that)
3) delete the audio track which was created during the import

When I repon my ardour project - it has lost the audio file which was imported.

If i am not doing step3, then it is all fine.

What's going on here?

Thank yoy

raptor59
User offline. Last seen 1 year 6 days ago. Offline
Joined: 2014-03-29
Posts:

*repon = reopen, sorry for type

veda_sticks
User offline. Last seen 4 days 8 hours ago. Offline
Joined: 2011-03-11
Posts:

Sounds like a bug, can you reproduce this?

There has been reports of audio files going missing, maybe this can shed a little more light or maybe this is a different bug.

dbra
User offline. Last seen 5 days 17 hours ago. Offline
Joined: 2012-12-27
Posts:

Or this is hopefully a reproductible way the bug occurs so it can be fixed... :)

febros
User offline. Last seen 11 weeks 6 days ago. Offline
Joined: 2013-09-21
Posts:

I don't have this problem using Ardour-3.5.74-dbg. The file is still there, but anyway I get this error message:

[ERROR]: could not reconstitute StatefulDiffCommand from XMLNode. object type = ARDOUR::AudioPlaylist id = 5291

paul
paul's picture
User offline. Last seen 4 hours 57 min ago. Offline
Joined: 2006-03-16
Posts:

The bug(s) are believed fixed. I will be doing a candidate build for testing in the next 24-36 hours.

dbra
User offline. Last seen 5 days 17 hours ago. Offline
Joined: 2012-12-27
Posts:

Thanks. I'm really looking forward for this one.

raptor59
User offline. Last seen 1 year 6 days ago. Offline
Joined: 2014-03-29
Posts:

Thank you Paul!