behringer x1204 records but doesnt playback

25 replies [Last post]
dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

hi there. i've been searching and had no answer to the fact that the behringer x1204 wourking through ardour records but doesnt play the recorded track.....so hope this can be solved here...

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

theres is a new behringer x1204 runing on ubuntu studio ¿, with ardour and alsa driver.

the matter is that i can record through the mixer but when i want to play that recorded track over ardour it just doesnt sounds....there is a waveform and recognition in the chanel, but it doesnt sounds....just when i do export to wav or flac i can hear the record

so, thanks and hope someone could help

veda_sticks
User offline. Last seen 15 hours 11 min ago. Offline
Joined: 2011-03-11
Posts:

this isnt an ardour specific problem. its more likely a driver issue or that ardour is not routed to the correct outputs.

Its possible that playback 1 and 2 are not the outputs that are connected to your speakers. Use the patchbay to try different outputs.

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

ok....but the only outputs patchage or jack shows are those called system playback 1 and 2.....and those arent working nor for laptop speaker or the mixer's outs

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

look. this is the actual setup

http://subefotos.com/ver/?895394b15b1087c792c8771b4eb28f34o.png

http://subefotos.com/ver/?160c6b49823d84f94f98b45d7c6cc8f9o.png

paul
paul's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-03-16
Posts:

i suggest checking that you've told JACK to use the correct device and that it has successfully done so.

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

Do you have duplex mode enabled in qjackctl? This will make sure that your device is using both inputs and outputs. If you don't have this enabled, you might only have your device inputs selected, which might be the root of them problem.

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

Also, as per Paul's suggestion, are you certain that the recorded signal is coming from the Behringer device? Some of those mixers have various routing options, which also include what is being sent to the outputs. Have you made sure this is set up correctly for playback?

veda_sticks
User offline. Last seen 15 hours 11 min ago. Offline
Joined: 2011-03-11
Posts:

"To make computer playback go through to the Control Room knob (and then out through the Control Room outputs) you need to depress the "2TR/USB" button to the left of the "PHONES/CTRL RM" knob. To make the mixing desk microphone/line inputs go to the Control Room level knob you need to depress the "MAIN MIX" button."

this might be your answer

veda_sticks
User offline. Last seen 15 hours 11 min ago. Offline
Joined: 2011-03-11
Posts:

ive just looked at your photos, the outputs from your tracks are not connected anywhere. they need tobe connected to the master in. Looking at your patching audio out on your tracks are not connected anywhere

paul
paul's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-03-16
Posts:

veda_sticks - good catch! why didn't i notice that? dparago: you should have left the default options in place for track input + output connections. It appears that you either disabled automatic connections or you manually disconnected them.

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

for the first, yes, the recording signal comes from the behringer device because when i do export as mp3 or flac i can listen to what y played......so this is right....

and about the connections all i can understand is that the ardour outputs are connected to system playback 1 and 2 and it doesnt sounds through the pc nor the mixer......and there are no more "playback" devices....

for that about duplex mode and automatic connections i have no idea about that....i mean, i havent modified this parameter as i dont know where they are....leatus penguin

the routing through the buttons are ok.......i have tested them with some windows soft and they are fine as you said, veda-sticks

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

@ dparago: The issue seems to be that the outputs from your tracks aren't going into the master channel. If the master channel is connected to your playback device (via monitor) it will play back whatever is being fed into it. However, from your connections, nothing is being fed into the master track.

This should happen by default so you may have disabled this option. Go to edit > preferences and click on the audio tab. You will see a heading called "Connection of tracks and busses". It sounds like this has been disabled so that these connections aren't automatically being made for you. If so, enable this option.

To manually do this from within Ardour, click on the bottom button of the tracks channel strip. This will show up a matrix router. Click on the "Ardour buses" tab and make sure your tracks are connected to the master channel here.

veda_sticks
User offline. Last seen 15 hours 11 min ago. Offline
Joined: 2011-03-11
Posts:

your audio out 2 and audio out 3 arnt going anywhere.

Im not sure why you were able to export and the exported file was fine though, as it should take it from the master out. You should have had a silent audio file

route the output of your recorded tracks to the master bus and you should here audio.

nedzad
User offline. Last seen 7 weeks 1 day ago. Offline
Joined: 2011-09-06
Posts:

Hi dparago, i would like to know how long you use your behringer pult, and do you have a manual?
What software plays your exported tracks, and is it jack software or "just" audio player working
direct with alsa? Do you use phonon

http://www.youtube.com/watch?v=3TF2r6Eimt4
........ two buttons in master section. Both are red colored, and left one is recording mode "activator"
other one ( on the right side ) is a listening "activator". So, "somehow" this pult ( i must use 4 of them :) isn´t user friendly machine. :)
Surface of this product is "super confusing shock"!

As i can see, your jack routing is confusing me.
If you record tracks, you set them to master as out when you listen them ( masters of ardour)
and masters are connected to system playback.

Why you use monitor/audio 1 and 2 ?

paul
paul's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-03-16
Posts:

dparago: the ardour outputs are connected to system playback 1 and 2 ... the only outputs connected to system:playback 1 and 2 are the monitor outputs and the auditioner outputs. Your actual track outputs are not connected to anything. Ardour does not do this by default.

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

ok, leatus penguin, the autoconnection within ardour is enabled....and, doesnt happens anything. but, when i manually go to the bottom button for the chanel strip and enable the arodur buses with audio 2 out i start recieving signal within the master as shown n the first pic:

http://subefotos.com/ver/?4cd9922147548e36fc57911fc749fbc6o.png

but still not doing any noise through none of the behringer outputs....

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

and this is how it is actual state of the conexions http://subefotos.com/ver/?88c3d13e5d7bcc5ef4cece69a9229a76o.png

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

Ardours master out isn't connected to your playback system

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

sorry brother, can you be more speciffic....i mean, which one should i plug onto what....

thanks again!

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

Connect -

master/audio_out 1 into playback_1
master/audio_out 2 into playback_2

dparago
User offline. Last seen 1 year 1 week ago. Offline
Joined: 2014-06-19
Posts:

ok, i pluggerd mastr audio out 1 and 2 into system playback 1 and 2...but still making not aniy sound....

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

If you have signal coming through your master meters, it's connected to your playback system, and you still have no sound, there are only two things i can think that are wrong. First is that you haven't told Jack to use the correct device. In the case that you definitely have the correct device selected, are you sure that you have it set up correctly for playback? Refer to veda_sticks post above about making computer playback work with that device.

paul
paul's picture
User offline. Last seen 2 hours 44 min ago. Offline
Joined: 2006-03-16
Posts:

Of course is isn't making any sound.

I said above: Your actual track outputs are not connected to anything

You either manually disconnected them, or you chose the option to manually connect them, and then failed to do so. Both are mistakes in almost every case.

I suggest (strongly) that you start a new session, make sure that automatic connection is enabled by default ("Advanced Options") in the new session dialog.

veda_sticks
User offline. Last seen 15 hours 11 min ago. Offline
Joined: 2011-03-11
Posts:

you need to connect your tracks to ardours master inpiut, just like you would assign on a real desk the channels to "master" or "mix channels in ardour need to be assigned somewhere if its not done by default. in the mixer screen at the bottom of your track theres a box, right click it and youw ill get a list of connections. select master

LeatusPenguin
User offline. Last seen 2 weeks 1 day ago. Offline
Joined: 2010-12-16
Posts:

In the last screenshot, his track outputs are connected to his master inputs. His master outputs weren't connected to his playback system though.