midi control

4 replies [Last post]
charly
User offline. Last seen 6 years 49 weeks ago. Offline
Joined: 2007-04-04
Posts:

hello, i am new in ardour and i am french...excuse my english....i try to control ardour with evolution uc33 in midi .
no problemes to use faders, but i cant use midi on lecture, stop, rewind, ...is it normal ?

and if i try to control plugins in midi, the plug bug, no sound and only the extrems values appears ....

!!!!! i hope you can understant me .

thanks

paul
paul's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

which version of Ardour are you using?

charly
User offline. Last seen 6 years 49 weeks ago. Offline
Joined: 2007-04-04
Posts:

i am on studio to go, ardour 0.99.3 (built with ardour gtk 1.4.1 libardour 0.908.2)

thanks

paul
paul's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

with 0.99.3 the transport buttons respond only to MIDI Machine Control (a standard for controlling various "tape-like" devices) or MIDI Song Position Pointer messages (a standard for controlling "sequencers"). you cannot bind arbitrary controllers to them. this has been changed in ardour 2.0.

as for the plugin issue, i haven't ever seen or heard of this before. you should be able to display the plugin editor, ctrl-middle-click on the plugin parameter control and bind a MIDI controller to it, just as for the main gain faders.

charly
User offline. Last seen 6 years 49 weeks ago. Offline
Joined: 2007-04-04
Posts:

ok thank you, the problem was i use touchpad and ctrl and not the mouse middle click .