"gthread-2.0 >= 2.10.1 not found" on ubuntu fiesty

9 replies [Last post]
DeathByGuitar
User offline. Last seen 5 years 21 weeks ago. Offline
Joined: 2007-04-22
Posts:

Ok, I'm getting this gthread-2.0 >= 2.10.1 not found" message when trying to compile it using the instructions on the website. Does this mean i need to update gthread? Synaptics says i have the latest version of gthread....I think....

What now?

Benjamin Scherrer
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2006-07-27
Posts:

Hi,

the most common mistake is to forget the development package. You might have installed gthread, but not dev package of it (was also my prblem once).

If this is not your problem, look at synaptics for the exact version installed. I'm sure you can see that somewhere.

Cheers,
Benjamin

paul
paul's picture
User offline. Last seen 19 hours 26 min ago. Offline
Joined: 2006-03-16
Posts:

some recent but not totally current versions of many distributions do not include a new enough version of glib to allow compilation of ardour. it doesn't mean that you can't run ardour if you have such a system, but it does mean that you can't compile it. what version does synaptics say is installed?

Seb
Seb's picture
User offline. Last seen 7 hours 13 min ago. Offline
Joined: 2006-04-07
Posts:

funny thing that. Can't seem to find a package related to "gthread" or "libgthread" on my (Feisty) system. But libgthread-2.0 is installed (as per "locate libgthread", and ardour2-rc1 compiles OK. Good luck. Can anyone remember the command to find out which .deb provides a particular file?

seb

DeathByGuitar
User offline. Last seen 5 years 21 weeks ago. Offline
Joined: 2007-04-22
Posts:

ok, i got rid of the glib thing, but now it's doing it with librdf saying that 0.4.0 wasnt found. i installed all the versions of it in synaptic, and yeah.....nothing....

any ideas?

DeathByGuitar
User offline. Last seen 5 years 21 weeks ago. Offline
Joined: 2007-04-22
Posts:

nevermind. i think i have this crap down. i installed stuff named librdf not liblrdf...damn syntax..

Seb
Seb's picture
User offline. Last seen 7 hours 13 min ago. Offline
Joined: 2006-04-07
Posts:

could that be version 1.0.4.1? I have that, (came with feisty) and it works, as I said. I'm sure you know from http://ardour.org/building that you need the respective developers packages "packagename-dev" in most cases.
For me, building ardour for the first time was a long cycle of
1) run scons until it gets stuck
2) scroll back to the first "error" (later errors are not useful), try to figure what header file is missing
3) google for the header file, guess what package is needed
4) apt-get install it, or use synaptic
5) repeat until scons doesn't get stuck any more!

DeathByGuitar
User offline. Last seen 5 years 21 weeks ago. Offline
Joined: 2007-04-22
Posts:

ok, i think this may be the last thing....

it says the system has no functional C++ compiler. where do i get that from?

sampo
User offline. Last seen 11 weeks 20 hours ago. Offline
Joined: 2006-03-16
Posts:

On debian based systems, you should install a package called "build-essential". You're probably really missing the C++ compiler, build-essential will make sure both gcc (for C) and g++ (for C++) are installed.

metadave
User offline. Last seen 5 years 51 weeks ago. Offline
Joined: 2008-04-27
Posts:

I just stumbled upon this thread. I have installed Ubuntu 8.0.4 and had the same problem with gthread.

Just install the libglib2.0-dev from the Synaptic Manager.

Cheers -
Dave