Playback doesnt work at all

29 replies [Last post]
tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

Hi@all,

I´m really new to Ardour b/c I´m trying to move to Linux and searched for a software I can mix my 16-track records. I installed ubuntustudio 7.04 and ardour 2.0 (built from revision 1762).

I imported some recorded tracks but I didn´t get the simple playback working. When clicking the playback button (>) nothing happens. The button doesn´t stay pressed. No playback line or something like that.

Before starting ardour I started JACK and audio playback with other applications (browser, musicplayer) works well.

Can anybody give me a hint what to do? I search the manual and tutorial but couldn´t find a helping hand ...

Thanks,
tabster

sampo
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-03-16
Posts:

Did you press the play button in Ardour, or in qjackctl?

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

I pressed the Start button in qjackctl and the PLAY button in Ardour! But nothing happens ...

sampo
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-03-16
Posts:

The start button in qjackctl does nothing unless Ardour (or other jack transport clients) are configured as jack transport slaves.

What sync settings do you have when the play button in Ardour doesn't work? See the combo selector box on the right of the two clocks and the button below it. Playback should always work when it's set to "internal" and time master.

One other possibility for playback to not work would be if ardour was disconnected from jack. That you can check from the qjackctl connections page. If you don't see any audio inputs or outputs for Ardour, it's not connected.

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

In Ardour it´s set to internal an Timemaster. In Ardour´s JACK menu it also seems to be connect b/c the connect entry is disabled, only disconnect is available.

In qjackctl I see that Ardour is connected to my soundcard.

See the images, maybe you can find sth useful:

http://img168.imageshack.us/img168/5229/bildschirmfotoconnectioxk6.png
http://img483.imageshack.us/img483/950/bildschirmfotoosterntesso6.png

sampo
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-03-16
Posts:

Weird.

Do you see the end marker anywhere in that session? If that marker is by mistake at the start of the session, playback might not start at all. If you don't see the marker anywhere, try moving the start marker and see if there's another marker below it.

If that doesn't help, you should try changing the sync to something other than internal and then changing it back to internal.

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

Hmm ... start marker is at the beginning and end marker at the end. There are no other markers.

I also tried to change the sync to MTC or JACK and back to internal but nothing helped.

sampo
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-03-16
Posts:

Can you move the playhead (the red cursor) manually? What if you drag the "shuttle" (above "stop", "%" and "Feder") control to the right?

Btw. Which translation are you using?

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

I can move the red cursor (also the blue one), if we mean the same. I moved it a bit to the right and shot a foto ... maybe you can check if we mean the same.

http://img519.imageshack.us/img519/5169/bildschirmfotoosterntesdv4.png

I can drag the shuttle to the right. When I release the mouse button it snaps back to the middle. I can´t see anything changing when moving the shuttle ...

As I am from Germany ubuntustudio installed the german language version.

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

tabster, please check in the menus under Transport -> Options -> Sync Startup to Video. Is this option checked?

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

hi paul, this option was not checked. but checking also didn´t change anything. maybe there´s something else wrong with my (sound)system? ... but I don´t have an idea what to check ...

nowhiskey
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-09-30
Posts:

hi,
since sampo put the question about the translation into this thread, perhaps it is worth of trying to start ardour with:

'LANG=en_US.UTF-8 /usr/bin/ardour2'

as i suppose that ardour2 is installed in /usr/bin.

i am on a german keyboard here too, and using the 'LANG...' prefix solved here some very strange issues too.

cheers,
doc

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

nowhiskey, changing to the en_us version didn´t help ...

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

is anyone out there who can help me?
maybe i should provide some more information about my system, but i dont know which.
please help me!

nowhiskey
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-09-30
Posts:

perhaps it is worth of trying - you build 2.0-ongoing from svn.
there are instructions at this page available how to do it.
my first ardour was ardour-beta23 and it was packaged by agnula, but as soon i switched to use a selfmade ardour, it became less fragile here.

cheers,
doc

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

okay, thanks for the hint. i´ll try it. on the page http://ardour.org/building i found the required libraries and installed them using the synaptic package manager. then i downloaded the 2.0.2 sources.

but i can´t find the commands i have to execute for building ardour itself. can u give me a hint?

and: should i uninstall ardour and jack at first?

nowhiskey
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-09-30
Posts:

you should not have to do anything with jakc, as it is already running at your machine?!
i think it is not a bad idea to uninstall ubuntu-ardour2 first

cd into dir where you saved the tarball, than do :
'tar xvjf ardour-2.0.2.tar.bz2'
the tarball will get unpacked.
when this is finished and you are on the prompt again, cd into the sourcetree:

'cd ardour-2.0.2'

and than type 'scons -j2'

it should take about half hour to compile, than become su(passwort) and type:
'scons install'

if you don't get any errors, ardour2 will be installed in /usr/local/bin/ardour2, so you have to change the menu entry for starting it, since it is pointing to /usr/bin/ardour2 in the moment.

you also can compile with:
'scons -j2 PREFIX=/usr' than you start ardour2 with '/usr/bin/ardour2'.
i have ardour2 compiled in /usr/local

hope this helps?!

cheers,
doc

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

so, i compiled ardour as you described. everything worked without a problem. thanks for your description. then i started ardour by typing /usr/local/bin/ardour2 on the command line. but there is the same problem as before: pressing the play button in ardour doesnt do anything.

maybe it´s because of another application or because of a problem with jack? do u have an idea?

nowhiskey
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 2006-09-30
Posts:

look, if you are able to place a playhead (the red line) by simply clicking in the timecode line (the black one on the top), you could try to switch the 'auto play'funktion on.
than, ardour should start playing automatically, everytime you click in the timeline.

cheers,
doc

Brian Watkins
User offline. Last seen 6 years 45 weeks ago. Offline
Joined: 2007-05-29
Posts:

I am having this exact problem runing UbuntuStudio

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

no, clicking the timecode line doesnt do anything.

tabster
User offline. Last seen 6 years 46 weeks ago. Offline
Joined: 2007-05-21
Posts:

maybe i´ll try fedora core with planet ccrma next week, but doing it with my current ubuntustudio version would be the better choice for me atm.

esmtll
User offline. Last seen 6 years 41 weeks ago. Offline
Joined: 2007-07-01
Posts:

I'm having the same problem running UbuStu. JACK is connected and I've checked everything as listed above. It seems this isn't a singular error.

nosay
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2007-09-16
Posts:

My ardour session freezed as I was performing an export. After a restart, ardour behaved the same as yours, unable to play.
I restarted jack since all jacked applications were unable to play. Problem solved for me.

Jack's logs gave me only one hint :
process cycle within freewheel failed

Void Main
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2007-11-02
Posts:

I installed the ardour2-2.1-1.fc7.ccrma.i386.rpm on my IBM Thinkpad running Fedora 7. Worked like a charm. In fact I copied over some tracks I had recorded in CoolEditPro several years back and quickly figured the basics out and mixed down a nice track. Very impressive!

Seeing that my Echo Layla20 is now supported under Linux and by Ardour I decided to dig it out of the garage and stick it in my desktop machine (also running FC7). I installed it and the same Ardour RPM and I am getting the exact same behavior that the original poster in this thread describes. I click the play button and nothing happens. If I double click on a WAV file in the file list for "Add Existing Audio" it doesn't play like it does on the laptop.

Everything seems to be configured the same. Is there something I can do to debug this? I would have no problem building the SVN version and adding patches, etc.

Thanks!

P.S. No really. Thank you for this app!

Void Main
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2007-11-02
Posts:

I just built the svn head and it didn't fix the problem.

Jonathan Stowe
User offline. Last seen 6 years 21 weeks ago. Offline
Joined: 2007-09-21
Posts:

That this happens when using one soundcard and not another would suggest that the problem lies elsewhere than Ardour. Have you tried to play back via another JACK aware application without using Ardour at all? The easiest way to do this would be to start jackd and then run "jack_metro -b 100" and then use e.g. qjackconnect to connect the output of jack_metro to the JACK playback ports - you should hear a metronomic tone. If this doesn't provide any output then it would indicate that your soundcard isn't playing nicely with JACK: it might be useful if you could start jackd from the command line and then paste the entire output. Also checking that non-jack applications can playback directly via this card would be useful.

Void Main
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2007-11-02
Posts:

Actually it works fine on one machine (laptop) and I didn't think it worked at all on another machine (desktop). It does appear to be JACK related though as I am able to get it to work (somewhat) with my Layla but it doesn't work at all using the built-in card (C-Media). I thought that setting the timecode to "internal" would effect on whether it uses JACK or not. All my other sound apps have always worked with the internal soundcard (including Hydrogen) but I guess they do not rely on JACK. Hmmm, at least I'm getting somewhere thanks to some pointers of yours. Here's what ALSA sees:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 2: CMI8738-MC6 [C-Media PCI IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Layla20 [Layla20], device 0: Analog PCM [Layla20]
Subdevices: 10/10
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
Subdevice #8: subdevice #8
Subdevice #9: subdevice #9
card 1: Layla20 [Layla20], device 1: Digital PCM [Layla20]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

Thanks!

Void Main
User offline. Last seen 6 years 3 weeks ago. Offline
Joined: 2007-11-02
Posts:

I ended up getting it working on my desktop machine with the C-Media (CM8738). I just had to play with the device settings in qjackctl. Now, if only I could get the S/PDIF input working so I can record directly from my Digitech GNX3.

hippie
User offline. Last seen 2 years 51 weeks ago. Offline
Joined: 2008-06-09
Posts:

Not trying to sway anyone away from Ubuntu, but if you're looking for another alternative for everything multimedia, 64Studio Linux is probably the best multimedia distro available. Best part... jack, jackEQ, Ardour, hydrogen, etc... are all preinstalled and work. www.64studio.com